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Handling DASD Alarms for the Optical Channel Diagnosis Panel in an RH5485

Publication Date:  2015-06-18 Views:  110 Downloads:  0
Issue Description
Hardware configuration:
RH5485 server with two hard disks.

Figure 1 and Figure 2 shows an optical channel diagnosis panel. The DASD alarm indicator is in the red box. It indicates the hard disk driver status.

Figure 1 Optical channel diagnosis panel



Figure 2 Diagram of the optical channel diagnosis panel



Symptoms:

DASD alarms are generated on the optical channel diagnosis panel; the system error indicator is steady on; "00" is displayed in the checkpoint code display. If two hard disks are inserted in slots 6 and 7, the server cannot detect the hard disks. It is the same condition for slots 0 and 1. If the two hard disks are inserted in slots 1 and 2, the server can detect them. The integrated management module (IMM) log includes the following alarms:

1. I --  -- 9/23/2011:8:45:19 -- Remote Login Successful. Login ID: USERID from Web at IP address 10.142.67.199
2. I --  -- 9/22/2011:13:55:40 -- Rebuild completed for Array in system "Host"
3. I --  -- 9/22/2011:13:55:40 -- Critical Array "Host" has deasserted
4. I --  -- 9/22/2011:12:36:22 -- Rebuild in progress for Array in system "Host"
5. E --  -- 9/22/2011:12:36:22 -- Array in system "Host" is in critical condition
6. I --  -- 9/22/2011:12:33:54 -- Rebuild completed for Array in system "Host"
7. I --  -- 9/22/2011:12:33:54 -- Critical Array "Host" has deasserted
8. I --  -- 9/22/2011:12:33:43 -- "Host Power" has been turned on
9. I --  -- 9/22/2011:12:33:31 -- "Host Power" has been turned off
10. I --  -- 9/22/2011:12:17:33 -- Redundancy "Power Group 1" has been restored
11. I --  -- 9/22/2011:12:17:27 -- "Power Supply 1" has returned to a Normal Input State
12. I --  -- 9/22/2011:12:8:51 -- Rebuild in progress for Array in system "Host"
13. E --  -- 9/22/2011:12:8:51 -- Array in system "Host" is in critical condition
Handling Process
  • The DASD alarm indicator is lit on the optical channel diagnosis panel, indicating that the hard disk driver is faulty or removed.
  • If the checkpoint code indicator is blinking Cx and 00 alternately, the bus cannot be repaired.
  • According to the IMM log, the array is abnormal, and the RAID controller card data is being repeatedly reconstructed.
The preceding information indicates that the server array is abnormal. In this case, perform the following operations:

1.  Reinstall the following components:
Faulty hard disk driver
  • Backplane of the SAS hard disk driver
  • SAS cables
  • RAID controller card
  • Input/output (I/O) board components
Then restart the server.

2. If the problem persists after the previous steps are performed, delete the current RAID controller card array, and reconfigure its array.
Root Cause
DASD alarms indicate that the hard disk driver is faulty, that is, the hard disks, hard disk backplane, SAS cables, or RAID controller card is faulty. Faulty hardware and poor connection can cause DASD alarms.

DASD alarms and abnormal array introduced in the case are caused due to poor contact of the storage subsystem.
Solution
When DASD alarms occur, check the hard disks, and then reinstall the storage subsystem. Figure 3 shows a hard disk subsystem. In the figure, red cables indicate SAS cables used for connecting the hard disk backplane to the RAID controller card.

Figure 3 RAID controller card and hard disk subsystem

END