No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
MENU

Failure to View Live Video from an HIKSDK-compliant Camera

Publication Date:  2015-06-23 Views:  28 Downloads:  0
Issue Description
A camera is connected to the eSpace IVS platform through the HIKSDK protocol. After a user selects the camera and enables live video viewing on the eSpace IVS C/S client, the screen goes blank, image artifacts occur, or a message is displayed indicating live video viewing failure.
Handling Process
Step 1 Check whether the stream transmission protocol is correctly set on the eSpace IVS C/S client.
1. Log in to the eSpace IVS C/S client and double-click Devices on the Workspace tab page.
2. In the device list, double-click the camera. The Configuration window is displayed.
3. Choose Video Settings > Video Encoding Settings.
4. Check whether Transmission protocol is set to RTP over TCP.
 If no, correct it and check whether the fault is rectified.
If the fault is rectified, no further action is required. If the fault persists, go to Step 2.
 If yes, go to the next step.
Step 2 Check whether the camera has sent media streams.
1. Log in to the OMU portal of the server and enable the debug log function for the DCG.
2. Log in to the server where the camera is connected as the root user.
3. Run the tcpdump -i ethx host deviceIP -s0 -vv -w /home/devicetodcg.pcap command.

 ethx indicates the service network adapter in use, for example, eth0. If you do not know the specific network adapter, you can enter any, indicating that packets of all network adapters are captured. However, this will result in a too large size of captured packets.
 host deviceIP indicates that only communication packets between the server and the camera whose IP address is the value of deviceIP are captured.
 /home/devicetodcg.pcap indicates the directory where captured packets are stored.
4. Log in to the eSpace IVS C/S client, enable live video from the camera. About 2 minutes later, press Ctrl+C to stop capturing packets.
5. Go to the /home directory and obtain the captured packet devicetodcg.pcap.

To minimize disk usage, run the rm /home/devicetodcg.pcap command to delete devicetodcg.pcap from the server after obtaining it.
6. Use Wireshark to open devicetodcg.pcap and check whether the camera has sent media streams.

Media streams sent by the HIKSDK-compliant camera may not be RTP packets. Determine whether media streams exist based on the size of devicetodcg.pcap.
 If the file size is less than 200 KB, the camera has not sent media streams. Contact Huawei technical support engineers.
 If the file size exceeds 200 KB, the camera has sent media streams. Go to the next step.
Step 3 Check whether the video encoding format is MJPEG and whether the RTP packet length exceeds 2000 bytes.
1. On the eSpace IVS C/S client, open the Configuration window and choose Video Settings > Video Encoding Settings. Then check whether Encoding format is set to MJPEG.
 If no, contact Huawei technical support engineers.
 If yes, go to the next step.
2. Use Wireshark to check whether RTP packets exist.

An RTP packet contains the Inter leaved channel field, as shown in Figure 3-10.
Figure 3-11 Captured packets from the camera to the eSpace IVS platform


 If no, go to Step 4.
 If yes, go to the next step.
3. Check whether the RTP packet length exceeds 2000 bytes.

For example, RTSP Interleaved Frame, Channel:0x00, 8000 bytes shown in Figure 3-10 indicates that the RTP packet length is 8000 bytes.
 If yes, contact the camera vendor to modify the RTP packet length and check whether the fault is rectified.
If the fault is rectified, no further action is required. If the fault persists, contact Huawei technical support engineers.
 If no, contact Huawei technical support engineers.
Step 4 Check whether media streams sent by the camera are encoded using the H.264 protocol.
1. Go the directory where DCG logs are stored, /home/ivs_dcg/log/debug.
2. Use the SFTP tool to download all debug logs generated during packet capturing to the local computer.
3. Check whether Cannot found Nalu Head 00 00 00 01 exists in the logs.

If Cannot found Nalu Head 00 00 00 01 exists in the logs, the camera software version is not the latest. As a result, the sent media streams are encoded using the Hikvision proprietary protocol and fail to be parsed by the eSpace IVS platform.
 If yes, upgrade the camera software and check the fault is rectified.
If the fault is rectified, no further action is required. If the fault persists, contact Huawei technical support engineers.
 If no, contact Huawei technical support engineers.
Root Cause
 The stream transmission protocol is incorrectly set on the eSpace IVS C/S client.
 The camera has not sent media streams.
 Media streams sent by the camera are in MJPEG format and the RTP packet length exceeds 2000 bytes.
 Media streams sent by the camera are encoded using the Hikvision proprietary protocol instead of using the H.264 protocol.

 On the eSpace IVS platform, the MU provides a 2000-byte buffer for receiving media streams. If media streams sent by an HIKSDK-compliant camera are RTP packets in MJPEG format that exceed 2000 bytes, the eSpace IVS platform will drop the out-of-range RTP packets and cause data loss.
 If media streams sent by an HIKSDK-compliant camera are encoded using the Hikvision proprietary protocol, the eSpace IVS platform cannot play the media streams due to the failure to parse the media streams.

END