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The Message Indicating a Failure to Set Up an SSH Connection Is Displayed When a User Adds a Host Before Upgrading the VMU Two-Node Cluster

Publication Date:  2015-06-23 Views:  52 Downloads:  0
Issue Description
A user adds a host on the host management window of the iDeploy before upgrading the VMU two-node cluster. When the user clicks Check, the message Failure to set up the SSH connection is displayed, as shown in Figure 8-2.
Figure 8-2 Adding a host
Handling Process
Step 1 Check the network connection between the iDeploy host and the server.
1. Run the ping command on the iDeploy host.
 If the network is properly connected, go to Step 2.
 If the network is abnormal, check the network connection, IP address setting, network adapter status, and switch configuration to locate and rectify the network fault. Then go to the next step.
2. Check whether the fault is rectified.
If the fault is rectified, no further action is required. If the fault persists, contact Huawei technical support engineers.
Step 2 Check whether the SSH service on the server is normal.
1. Start the SSH terminal software on the iDeploy host and connect the software to the iDeploy host using the SSH protocol to check whether the SSH service is available and enabled on the server.
 If the software can be connected to the iDeploy host, or if the connection fails for the first time but succeeds for the next time, go to Step 3.
 If the software cannot be connected to the iDeploy host, go to the next step.
2. Log in to the server management page through the management port IP address of the server.
3. Choose Device Configuration > Start KVM. The KVM window is displayed.
4. Run the /etc/init.d/sshd status command to query the SSH service state.
 If the SSH service is in running state, contact Huawei technical support engineers.
 If the SSH service is not in running state, go to the next step.
5. Run the /etc/init.d/sshd start command to enable the SSH service.
6. Run the /etc/init.d/sshd status command again to check whether the SSH service is enabled.
 If the SSH service is disabled, contact Huawei technical support engineers.
 If the SSH service is enabled, check whether the fault is rectified.
If the fault is rectified, no further action is required. If the fault persists, go to the next step.
Step 3 Check whether eth-trunk is configured for the two ports on the switch that connect to the active and standby service network adapters of the server.
1. Log in to the switch console.
2. Run the display eth-trunk x command to check whether eth-trunk is configured on the switch. If eth-trunk is configured on the switch, the following information is displayed:

In the following information, eth-trunk x is the eth-trunk name.
Eth-Trunk0's state information is: 
WorkingMode: NORMAL Hash arithmetic: According to SIP-XOR-DIP 
Least Active-linknumber: 1 Max Bandwidth-affected-linknumber: 8 
Operate status: up Number Of Up Port In Trunk: 2 
-------------------------------------------------------------------------------- 
PortName               Status         Weight 
GigabitEthernet0/0/1    Up             1 
GigabitEthernet0/0/2    Up             1 

 If eth-trunk is not configured, contact Huawei technical support engineers.
 If eth-trunk is configured, go to the next step.
3. Check the binding between the switch ports and server ports and disable the eth-trunk configuration.

Here, the switch has two ports GigabitEthernet0/0/1 and GigabitEthernet0/0/2. Perform operations based on the actual condition.
a. Run the int GigabitEthernet 0/0/1 command to access the GigabitEthernet0/0/1 port.
b. Run the undo eth-trunk command to disable the eth-trunk configuration.
c. Run the int GigabitEthernet 0/0/2 command to access the GigabitEthernet0/0/2 port.
d. Run the undo eth-trunk command to disable the eth-trunk configuration.
4. Run the undo interface eth-trunk x command to delete the eth-trunk configuration. If the eth-trunk configuration is successfully deleted, the following information is displayed:
Info: This operation may take a few seconds. Please wait for a moment...succeeded. 

5. Run the display eth-trunk x command to check whether the eth-trunk configuration is deleted. If the eth-trunk configuration is successfully deleted, the following information is displayed:
Error: The trunk port does not exist.

 If the eth-trunk configuration is not deleted, contact Huawei technical support engineers.
 If the eth-trunk configuration is successfully deleted, go to the next step.
Step 4 Check whether the fault is rectified.
If the fault is rectified, no further action is required. If the fault persists, contact Huawei technical support engineers.
Root Cause
 The network between the iDeploy host and the server is abnormal.
 The SSH service on the server is abnormal.
 eth-trunk is configured on the switch, whose active and standby ports correspond incorrectly to the active and standby service network adapters on the server.

END