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The System Cannot Be Loaded from the Network Due to a Faulty CPU

Publication Date:  2015-06-25 Views:  132 Downloads:  0
Issue Description
The following table lists the configuration of an E6000. 



Symptom:

When loaded from the network by using the on-board NIC, the system reports BANK 5 and BANK 8 errors. The system cannot be loaded.

Handling Process
Based on the definition of the machine check exception (MCE) error code, if a CPU reports BANK 5, faults occur on Peripheral Component Interconnect Express (PCIe) devices; if the CPU reports BANK 8, faults occur on the memory controller or dual in-line memory modules (DIMMs). PCIe devices, DIMMs, and CPUs need to be checked.

NOTE:
PCIe devices in the E6000 include two NIC daughter boards and one RAID controller card.

Perform the following operations to check PCIe devices:

1.  Power off the server, and remove and reinstall NIC daughter boards. Then power on the server and restart it. The system reports BANK 5 and BANK 8 errors.

2.  Power off the server, and remove and reinstall the RAID controller card. Then power on the server and restart it. The system reports BANK 5 and BANK 8 errors.

3.  Power off the server, and replace NIC daughter boards. Then power on the server and restart it. The system reports BANK 5 and BANK 8 errors. Therefore, NIC daughter boards are normal.

4.  Power off the server, and replace the RAID controller card. Then power on the server and restart it. The system reports BANK 5 and BANK 8 errors. Therefore, the RAID controller card is normal.

Based on the preceding analysis, PCIe devices are normal.

Perform the following operations to check CPUs and DIMMs:

1.  Power off the server, and remove and reinstall all DIMMs. Then power on the server and restart it. The system reports BANK 5 and BANK 8 errors. In this case, go to step 2. Otherwise, remove and reinstall DIMMs in turns to determine whether DIMMs are faulty.

2.  Power off the server, perform the following operations on CPUs (if CPUs cannot be detected, the corresponding DIMMs are not used), and record the operation result. 



The preceding information indicates that DIMMs are normal. Check whether CPU 2 is faulty.

3.  Install the removed CPU 2 in a normal server (the main board is normal), power on and start the server. Then the system reports BANK 5 and BANK 8 errors.
Root Cause
Based on the preceding analysis, CPU 2 is faulty. Replace CPU 2.

Solution
Replace CPU 2.

Suggestions
If the CPU reports a message showing that a BANK code is incorrect, narrow down the check range based on the BANK code.

END