No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

The Client Properties Cannot Be Queried on the NetBackup Administration Console and Error Message "client connection refused (status 57)" Is Displayed

Publication Date:  2015-07-28 Views:  50 Downloads:  0
Issue Description
On the NetBackup Administration Console, choose NetBackup Management > Host Properties > Clients on the navigation tree. Right-click the Linux client and view the properties. Error message client connection refused is displayed and the error code is status 57.

Handling Process
Cause 1:

On the HDP3500E master server, add the resolution information about the host name and IP address of the NetBackup client.
On the NetBackup client, add the resolution information about the host name and IP address of the HDP3500E master server.

Cause 2: On the NetBackup client, enable the bpcd process.

1.  Restart the xinetd service. The bpcd service is managed by the xinetd service. Therefore, you can enable only the xinetd service to enable the bpcd service.


/etc/init.d/xinetd restart

2.  On the NetBackup client, run the netstat -a | grep bpcd command to check the bpcd listening status.

tcp   0      0 *:bpcd     *:*     LISTEN

The output information indicates that the bpcd is in the listening state.

Cause 3: When the firewall on the NetBackup client is enabled, enable port 13782 on the NetBackup client.

1.  Select the computer icon and click Manage. Choose Configuration > Windows Firewall with Advanced Security > Inbound Rules.





2.  Add new inbound rules and allow the port enabling operation. 




3.  Set the rule type to Port. 




4.  Specify a port, for example, 13782. You can specify multiple ports to be enabled.




5.  Select Allow the connection. 




6.  Select an application scenario.




7.  Enter the inbound rule name.




8.  The inbound rules for the bpcd process of the NetBackup client are created.


Root Cause
Possible Causes:
  1. The HDP3500E master server and NetBackup client are not properly connected.
  2. The bpcd process does not run on the NetBackup client.
  3. After the firewall is enabled on the NetBackup client, the HDP3500E master server fails to establish a connection with the bpcd process on the NetBackup client.
Fault Diagnosis:

Cause 1: Use the bpclntcmd and bptestbpcd commands to test the connection.


NOTE:
    The bpclntcmd command is used for resolving IP addresses and host names.
    The bptestbpcd command is used for testing the connectivity between the NetBackup server and the NetBackup system.


1.  Log in to the HDP3500E master server and NetBackup client as the root user.

2.  Resolve the host names and IP addresses of the HDP3500E master server and NetBackup client.
On the HDP3500E master server, perform the following operations:


Run the bpclntcmd -ip Client_IP command with Client_IP set to the IP address of the client. In this case, the IP address of the client is 129.31.65.212.

/usr/openv/netbackup/bin/bpclntcmd -ip 129.31.65.212
host 129.31.65.212: vm-ad1.vm.com at 129.31.65.212
aliases:     vm-ad1.vm.com     129.31.65.212


Run the bpclntcmd -hn Client_Name command with Client_Name set to the host name of the client. In this case, the host name of the client is vm-ad1.

/usr/openv/netbackup/bin/bpclntcmd -hn vm-ad1
host vm-ad1: vm-ad1.vm.com at 129.31.65.212
aliases:     vm-ad1.vm.com     vm-ad1     129.31.65.212


On the NetBackup client, run the bpclntcmd -pn command.

/usr/openv/netbackup/bin/bpclntcmd -pn
expecting response from server VM-Master
vm-ad1.vm.com vm-ad1 129.31.65.212 61233


The output information indicates that the host names and IP addresses of the HDP3500E master server and NetBackup client are correctly resolved.

Cause 2 and cause 3: Test the bpcd connectivity between the HDP3500E master server and the NetBackup client.

1.  On the HDP3500E master server, run the bptestbpcd -client client_Name command.


<16>bptestbpcd main: Function ConnectToBPCD(vm-ad1) failed: 25
cannot connect on socket


The bpcd is a resident program on the back end of the NetBackup. On the HDP3500E master server, when you check the client properties, the HDP3500E master server attempts to connect to the bpcd port (13782) on the NetBackup client. The output information indicates that the HDP3500E master server fails to connect to the bpcd port of the NetBackup client. The failure causes are as follows:
  • The bpcd process does not run on the NetBackup client.
  • After the firewall is enabled on the NetBackup client, the HDP3500E master server fails to establish a connection with the bpcd process on the NetBackup client.
2.  On the NetBackup client, run the netstat -a | grep bpcd command to check the bpcd listening status.

If no output is displayed, the bpcd process on the back end does not work.

END