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After the IP Address of the Client Is Changed, the HDP3500E Cannot Be Connected to the Client (Status 25)

Publication Date:  2015-07-29 Views:  80 Downloads:  0
Issue Description
On the NetBackup Administration Console of the HDP3500E, choose NetBackup Management > Host Properties > Clients on the navigation tree. Click the client to view the status. The client status is Connected.

After the IP address of the NetBackup client is changed and the hosts file and DNS are modified, check the client properties. Error message cannot connect on socket is displayed and the error code is 25.



Handling Process
1.  Method 1: Clear the cached host name and IP address on the HDP3500E master server.

a. Log in to the HDP3500E master server as the root user.

b. Run the following command to clear the cached host name and IP address on the HDP3500E master server.
    # /usr/openv/netbackup/bin/bpclntcmd -clear_host_cache

2.  Method 2: Delete all files in the host_cache directory.

The resident program on the back end uses the DNS in the host file to rebuild the host cache.

Root Cause
Possible Causes:

The cached host name and IP address on the NetBackup are not refreshed in a timely manner.

Fault Diagnosis:

After the IP address of the NetBackup client is changed, the HDP3500E master server does not refresh the cached host name and IP address of the NetBackup client in a timely manner. As a result, the NetBackup client and the HDP3500E master server are disconnected. You can run the bpclntcmd and bptestbpcd commands to test the connection.

NOTE:
The bpclntcmd command is used for resolving IP addresses and host names.
The bptestbpcd command is used for testing the connectivity between the NetBackup server and the NetBackup system.

Assume that 129.31.65.212 is the original IP address and 129.31.65.222 is the new IP address.

1.  Log in to the NetBackup master server and NetBackup client as the root user.

2.  Resolve the host names and IP addresses of the NetBackup master server and NetBackup client.

On the NetBackup master server, perform the following operations:
  • Run the bpclntcmd -ip Client_IP command with Client_IP set to the IP address of the client. In this case, the IP address of the client is 129.31.65.222.
/usr/openv/netbackup/bin/bpclntcmd -ip 129.31.65.222
host 129.31.65.222: vm-ad1.vm.com at 129.31.65.212
aliases:     vm-ad1.vm.com     129.31.65.212
  • Run the bpclntcmd -hn Client_Name command with Client_Name set to the host name of the client. In this case, the host name of the client is vm-ad1.
/usr/openv/netbackup/bin/bpclntcmd -hn vm-ad1
host vm-ad1: vm-ad1.vm.com at 129.31.65.212
aliases:     vm-ad1.vm.com     vm-ad1     129.31.65.212

The output information indicates that the host names and IP addresses of the HDP3500E master server and NetBackup client are not correctly resolved.

3.  Check the hosts file and DNS configuration. Ensure that the configuration is correct.

4.  On the HDP3500E master server, create the local name cache to save the mapping between host names and IP addresses. The paths of the local name cache are as follows:
  • Unix: /usr/openv/var/host_cache
  • Windows: \NetBackup\var\host_cache
Suggestions
When the HDP3500E master server attempts to establish a connection, the NetBackup saves the mapping between host names and IP addresses in the local cache to accelerate the searching of the server names and IP addresses. After the IP address of the client is changed, the NetBackup cannot identify the mapping between the host name and the new IP address. The NetBackup still uses the mapping between the host name and the original IP address.

END