No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

HBA Disconnection After the VTL Server Is Restarted

Publication Date:  2015-08-04 Views:  82 Downloads:  0
Issue Description
Product and version: VTL6000 V100R003

After you connect the VTL server to a storage unit controller enclosure and restart the VTL server or VTL service, the status of the HBA becomes Link down on the VTL Console.
Handling Process
1.  Check whether the Fibre Channel HBA driver of the VTL server is in NPIV mode.

     a. Start the Fibre Channel service of the VTL server.
     b. Set the HBA to work in target mode.
     c. Check whether the HBA icon is displayed as D.
  • If yes, go to 2.
  • If no, keep the application environment unchanged and seek technical support.
2.  Check whether the Fibre Channel port of the VTL server is in P2P mode.

     a. Log in to the VTL server using a Secure Shell (SSH) tool.
     b. Run the vi /usr/local/vtl/etc/fshba.conf command to check whether the Fibre Channel port of the VTL server is in P2P mode.
  • If yes, go to 3.
  • If no, go to 2.c.
     c. Set the mode of the VTL server's Fibre Channel port to P2P.

3.  Check whether the Fibre Channel port of the storage unit is in P2P mode.

     a. In the navigation tree of the Integrated Storage Manager (ISM) for storage units, choose Device Information > Port.
     b. In the function pane, click the FC Host Port tab and select the Fibre Channel port to check whether the port mode is P2P.
  • If yes, go to 4.
  • If no, go to 3.c.
     c. Set the mode of the storage unit controller enclosure's Fibre Channel port to P2P.

4.   Unload the Fibre Channel HBA driver and load it again.

     a. Log in to the VTL server using an SSH tool.
     b. Run the vtl stop all command to stop the VTL service.
     c. Run the vtl configtgt command to enter the Fibre Channel HBA driver configuration interface.
     d. Navigate to q and press Enter to unload all Fibre Channel HBAs.
     e. Run the vtl configtgt command again to enter the Fibre Channel HBA configuration interface.
     f. Navigate to qlogic and press Enter to unload all Fibre Channel HBAs.
     g. Run vtl start all to start the VTL service.

5.  On the VTL Console, check whether the HBA is connected.
  • If yes, the fault is rectified.
  • If no, keep the application environment unchanged and seek technical support.
Root Cause
Possible Causes:

The possible causes of this failure are that the Fibre Channel ports of the VTL server and storage unit controller enclosure are both in P2P mode while the Fibre Channel HBA driver of the VTL server is in NPIV. The two modes are mismatched.

Fault Diagnosis:

Figure 1 Troubleshooting flowchart


END