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A Backup Server Cannot Detect the Virtual Tape Library

Publication Date:  2015-08-04 Views:  26 Downloads:  0
Issue Description
Product and version: VTL6900 V100R005

The symptom is that a backup server cannot detect the virtual tape library.
Handling Process
Possible cause 1: The virtual tape library driver is not installed.

1.  Please check the website to download the corresponding virtual tape library driver, and correctly installed.

2.  Log in to the VTL server using the VTL Console. The default user name and password are root and Admin@storage respectively.

3.  Re-create a virtual tape library. For details, refer to the OceanStor VTL6900 Virtual Tape Library V100R005 Configuration Guide.

4.  Allocate the newly created virtual tape library to the backup server. For details, refer to the OceanStor VTL6900 Virtual Tape Library V100R005 Configuration Guide.

5.  On the backup server, rescan for the virtual tape library.
  • If the backup server can detect the virtual tape library, the fault is rectified.
  • If the backup server still cannot detect the virtual tape library, go to Possible cause 2.
Possible cause 2: The Fibre Channel port of the VTL server and the Fibre Channel port of the backup server have different WWPNs.

1.  Check the WWPNs of Fibre Channel ports on the VTL server and the backup server.

    a. Log in to the VTL server using the VTL Console. The default user name and password are root and Admin@storage respectively.
    b. In the navigation tree, choose Physical Resources > Storage HBAs > Qlogic Adapter xxx. On the General tab page, check WWPN.

NOTE:
xxx indicates a Qlogic adapter ID.

2.  On the backup server, check the WWPN of the port connected to the VTL server.
  • On a Windows-based backup server:
          When the backup server is being started, press Ctrl+Q to go to BIOS interface and check the WWPN of the backup server.
  • On a Linux-based backup server:
          Run the cat /sys/class/fc_host/host*/port_name command to check the WWPN of the backup server. * indicates the Fibre Channel port name.

3.  Reconfigure the Fibre Channel backup client. For details, refer to the OceanStor VTL6900 Virtual Tape Library V100R005 Configuration Guide.

4.  Re-create a virtual tape library. For details, refer to the OceanStor VTL6900 Virtual Tape Library V100R005 Configuration Guide.

5.  Allocate the newly created virtual tape library to the backup server. For details, refer to the OceanStor VTL6900 Virtual Tape Library V100R005 Configuration Guide.

6.  On the backup server, rescan for the virtual tape library.
  • If the backup server can detect the virtual tape library, the fault is rectified.
  • If the backup server cannot detect the virtual tape library, go to Possible cause 3.
Possible cause 3: When the VTL server is directly connected to the backup server, they have different models of Fibre Channel HBAs.

1.  Use optical fibers to connect the VTL server and the backup server to the Fire Channel switch.

2.  Configure the Fibre Channel switch. Assign the Fibre Channel switch ports connected to the VTL server and the backup server to the same zone. For details, refer to the OceanStor VTL6900 Virtual Tape Library V100R005 Configuration Guide.

3.  On the backup server, rescan for the virtual tape library.
  • If the backup server can detect the virtual tape library, the fault is rectified.
  • If the backup server cannot detect the virtual tape library, contact Huawei technical support.
Possible cause 4: The backup server is faulty.

Contact the manufacturer of the backup server to rectify the fault.

If the backup server cannot detect the virtual tape library, contact Huawei technical support.
Root Cause
Possible causes are:

Possible cause 1: The virtual tape library driver is not installed.

Possible cause 2: The Fibre Channel port of the VTL server and the Fibre Channel port of the backup server have different World Wide Port Names (WWPNs).

Possible cause 3: When the VTL server is directly connected to the backup server, they have different models of Fibre Channel host bus adapters (HBAs).

Possible cause 4: The backup server is faulty.

Fault Diagnosis:

Flowchart for troubleshooting the failure to detect the virtual tape library on the backup server

END