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The HBA Is in the Link Down State

Publication Date:  2015-08-04 Views:  109 Downloads:  0
Issue Description
Log in to the VTL Console. The default user name and password are root and Admin@storage respectively.

In the navigation tree of the VTL Console, choose Physical Resources > Storage HBAs > QLogic Adapterxxx.

NOTE:
xxx indicates the ID of the Fibre Channel port.

In the function pane on the right, click the General tab. The value of Port Status is Link Down.

Handling Process
Possible cause 1: The VTL server is disconnected from the peer device.

1.  Reinsert the HBA card, or the optical fiber that connects the VTL server to the peer device.

2.  On the VTL Console, rescan for physical resources and check the port status of the HBA.

a. Log in to the VTL Console. The default user name and password are root and Admin@storage respectively.
b. In the navigation tree of the VTL Console, right-click Physical Resources and choose Rescan from the shortcut menu.
    The Virtual Tape Library Console dialog box is displayed.
c. In the Virtual Tape Library Console dialog box that is displayed, click Yes.
d. In the Virtual Tape Library Console dialog box, select Scan for existing devices and click OK.

NOTE:
After the scan is complete, the scan result is displayed.

e. Check the port status of the HBA.
  • If the status is Link Up, the fault is rectified.
  • If the status is Link Down, go to 3.
3.  Replace the optical fiber that connects the VTL server to the peer device.

4.  On the VTL Console, rescan for physical resources and check the port status of the HBA.
  • If the status is Link Up, the fault is rectified.
  • If the status is Link Down, go to Possible cause 2.
Possible cause 2: The VTL server has a different Fibre Channel port mode from the peer device.

1.  Log in to the VTL server using PuTTY. The default user name and password are root and Admin@storage respectively.

2.  Run the vi /usr/local/vtl/etc/fshba.conf command.

3.  Press i to enter the edit mode, and reset connection_option-hba.
  • If the VTL server is directly connected to the peer device, change the value to 0 (LOOP mode).
  • If the VTL server is connected to the peer device through a Fibre Channel switch, change the value to 1 (P2P mode).
4.  Run the :wq ! command to save the setting and exit the edit mode.

5.  Run the vtl restart all command to restart all services of the VTL server.

6.  On the VTL Console, rescan for physical resources and check the port status of the HBA.
  • If the status is Link Up, the fault is rectified.
  • If the status is Link Down, go to Possible cause 3.
Possible cause 3: The HBA driver is corrupted.

1.  Log in to the VTL Console. The default user name and password are root and Admin@storage respectively.

2.  In the navigation tree of the VTL Console, choose Physical Resources > Storage HBAs > QLogic Adapterxxx.

NOTE:
xxx indicates the ID of the Fibre Channel port.

3.  Check whether a T symbol is displayed in the lower right corner of the QLogic Adapterxxx icon.

NOTE:
If a T symbol is found, the Fibre Channel port is in the Target state and the HBA driver cannot be uninstalled.
  • If yes, go to 4.
  • If no, go to 5.
4.  Right-click QLogic Adapterxxx and choose Disable Target Mode from the shortcut menu.
     The Disable Target Mode dialog box is displayed and subsequent operations are automatically completed.

5.  Log in to the VTL server using PuTTY. The default user name and password are root and Admin@storage respectively.

6.  Run the vtl stop all command to stop all services of the VTL server.

7.  Run the vtl configtgt command to enter the HBA driver configuration window.

8.  Enter q and press Enter to uninstall the HBA driver.

     The screen information is:

vtl server removed the target mode HBA support

The HBA driver has been successfully uninstalled.

9.  Run the vtl configtgt command to enter the HBA driver configuration window.

10.  Enter qlogic and press Enter to load the HBA driver.

The screen information is:

VTL server will use QLogic 2x00 () as the target mode HBA

The HBA driver has been successfully loaded.

11.  Run the vtl start all command to start all services of the VTL server.

12.  On the VTL Console, rescan for physical resources and check the port status of the HBA.
  • If the status is Link Up, the fault is rectified.
  • If the status is Link Down, contact Huawei technical support.
Root Cause
Possible Causes:

Possible cause 1: The VTL server is disconnected from the peer device.

Possible cause 2: The VTL server has a different Fibre Channel port mode from the peer device.

Possible cause 3: The HBA driver is corrupted.

Fault Diagnosis:

Figure 1 Troubleshooting flowchart



END