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eSpace U1960 doesn’t receive message notification from Movius server for voicemail message system

Publication Date:  2015-10-10 Views:  64 Downloads:  0
Issue Description

When internal user A deposit a voicemail for another internal user B, this message must be notified to the intended user B, but user B don’t receive any notification of voicemail, also eSpace U1960 don’t send any  notification of voicemail new message to user B.
Topology:

eSpace U1960: V100R001C20SPC500
Movius Café  Nano 3.3.163
User A and User B: eSpace 7910: V200R002C00SPC200

Alarm Information
None.
Handling Process

Applied command “show subscriber dn B” in PBX for check “NewMsgs” field and found the values is 0.

Then Capture packets between the movius server and PBX U1960.


74.001625  172.16.70.1 -> 172.16.70.5  SIP/SDP Request: INVITE sip:1521@172.16.70.5:5060;user=phone, with session description
74.002406  172.16.70.5 -> 172.16.70.1  SIP Status: 100 Trying
74.002412  172.16.70.5 -> 172.16.70.1  SIP Status: 100 Trying
74.036476  172.16.70.5 -> 172.16.70.1  SIP/SDP Status: 200 OK, with session description
74.036483  172.16.70.5 -> 172.16.70.1  SIP/SDP Status: 200 OK, with session description
74.109623  172.16.70.1 -> 172.16.70.5  SIP Request: ACK sip:1521@172.16.70.5:5060
92.849804  172.16.70.1 -> 172.16.70.5  SIP Request: BYE sip:1521@172.16.70.5:5060
92.850041  172.16.70.5 -> 172.16.70.1  SIP Status: 200 OK
92.850045  172.16.70.5 -> 172.16.70.1  SIP Status: 200 OK
93.910060  172.16.70.5 -> 172.16.70.1  SIP Request: NOTIFY sip:@172.16.70.1
93.910072  172.16.70.5 -> 172.16.70.1  SIP Request: NOTIFY sip:@172.16.70.1
93.920337  172.16.70.1 -> 172.16.70.5  SIP Status: 400 Bad Request
120.999598  172.16.70.1 -> 172.16.70.5  SIP Request: OPTIONS sip:172.16.70.5:5060
120.999826  172.16.70.5 -> 172.16.70.1  SIP Status: 200 OK
120.999831  172.16.70.5 -> 172.16.70.1  SIP Status: 200 OK
241.998931  172.16.70.1 -> 172.16.70.5  SIP Request: OPTIONS sip:172.16.70.5:5060


Found when Movius Server sent notification voice message (NOTIFY) to our PBX, PBX sent respond “400 bad request error”

 

Root Cause

The Notify Message sent by Movius server to PBX, don’t accomplish the RFC3261 about the SIP URI components, SIP URI user part is missing.
Movius must send the general form for SIP URI:  sip:user:password@host:port;uri-parameters? headers  in order to our PBX don’t send message “400 bad request”.

Capture packets to  test and probe in lab where this scenario works and compare with other is not working:

 

Solution

Modified the configuration at Movius system side made by Movius personnel for how the notification message is send in order to follow the RFC3261. Movius now send the user part and PBX receives and accepts the notification.


Using again command “Show subscriber dn B” now appear new messages:

Suggestions
None.

END