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Mono Audio Input on a ViewPoint 9039S, Causing Audio Discontinuity

Publication Date:  2015-10-28 Views:  94 Downloads:  0
Issue Description

To input audio into an endpoint, connect the microphone to the tuning console and connect the tuning console to the Audio IN L port of the endpoint.

l   When the format of audio sent by the endpoint is AAC_LD mono (that is, the audio protocol is set to a mono one on the SMC), the audio is sent properly to other endpoints.

l   When the format of audio sent by the endpoint is AAC_LD stereo (that is, the audio protocol is set to a stereo or auto one on the SMC), the audio sent to other endpoints discontinues.

Handling Process

Capture packets from the live network, use necessary tools to restore audio, and conduct an analysis on the audio. Discontinuity occurs on stereo audio sent by the endpoint. This symptom is the same as that occurs on the live network.

If the audio input port that is not connected to any audio device is disabled on the endpoint (as shown in Figure 1-1), audio discontinuity disappears.

Figure 1-1 Disabling the audio input port that is not in use

Root Cause

AAC_LD mono audio processing:

If an endpoint encodes audio in AAC_LD mono format after joining a conference, the endpoint combines audio collected from left and right audio channels into a single channel of audio and sends the combined audio to the remote endpoint. Then the endpoint copies the combined audio and outputs the received and copied audio from the left and right audio channels respectively.

Figure 1-1 AAC_LD mono audio processing

 

AAC_LD stereo audio processing:

If an endpoint encodes audio in AAC_LD stereo format after joining a conference, the endpoint encodes audio collected from left and right audio channels and sends the encoded audio to the remote endpoint. Then the endpoint outputs the received audio from the left and right audio channels.

Figure 1-2 AAC_LD stereo audio processing


 

The AAC_LD stereo audio fault occurs due to incorrect cable connections.

Figure 1-3 AAC_LD stereo audio fault

 

If only the left audio input channel is connected on the local endpoint and only the left audio output channel is connected on the remote endpoint, no audio will be output on the remote endpoint.

To prevent this fault, when unmuting an audio input port, the system detects audio input on the port.

The procedure for detecting audio input is as follows:

                               Step 1     Detect the energy of the Audio IN L and Audio IN R ports for 0.3s. If the energy of the Audio IN L or Audio IN R port is lower than the threshold, the port is identified as not connected.

                               Step 2     If the Audio IN L port is not connected, copy the data of the Audio IN R port to the Audio IN L port, which takes only 1s.

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If the conference room on the live network is quiet or background noise differs for endpoints, inaccurate judgment may happen when you pause during your conversation, for example, counting. For example, the Audio IN L port that is connected to an audio device will be identified as no input. Then data will be copied from the Audio IN R port to the Audio IN L port, resulting in audio discontinuity.

Solution

                               Step 1     Log in to the endpoint web interface.

                               Step 1     Choose Device Control > Audio Control.

                               Step 2     In the Audio Input area, deselect Unmute for the audio input port that is not connected to any audio device.

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