No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

E9000 CH121 blade server can't get IP address from DHCP server

Publication Date:  2015-11-24 Views:  102 Downloads:  0
Issue Description

There are 16 CH121 V3 blade server in total ,and only one of them can't get ip address from DHCP server, others are fine.

 


Alarm Information
no alarm message.
Handling Process

There are below possible cause for the server can't get ip from DHCP:

1, there is no available ip address in the DHCP server address pool;

2, there is something wrong with network between the DHCP server and blade;

3, there is something wrong with the blade or the mezz card.

Accroding to above possible cause:

1, we checked the DHCP server, there is enough ip address in address pool;

2,because other blade works fine, and the configuration in switch panel is the same for all blade, so the network is fine.

3, we collected the server logs, and found below information: 

 

for the normal blade:

Mezz Card Info
Slot | BoardId | Name | Manufacturer | PCB Ver | Card Desc
1 | 0x80 | MZ110 | Huawei | .B | 4*GE Port Mezzanine Card
2 | 0x88 | MZ611 | Huawei | .A | 2*56G HCA Mezzanine Card

for the blade that can't get ip from DHCP:

Mezz Card Info
Slot | BoardId | Name | Manufacturer | PCB Ver | Card Desc
1 | 0x88 | MZ611 | Huawei | .A | 2*56G HCA Mezzanine Card
2 | 0x80 | MZ110 | Huawei | .B | 4*GE Port Mezzanine Card

According to above information, to this rack, the slot1 connets to the GE switch module.and the slot 2 connects to IB switch module.That means the last blade, the mz110 also shoule be in the slot1 and mz611 should be in slot2.

 

 

Root Cause

If the switch module is inserted, that means all the slot1 of blade could connect to GE switch or IB switch. In the time, the slot1 connects to the GE switch module, but all slot2 connects to IB switch module. And  the mz110 card is GE type, so it should be inserted to the slot1.

Solution
swap the mezz card in slot1 and slot2 and problem fixed
Suggestions

This kind of issue could happen in all the blade server. We should check that the mezz card communicates to the right switch module.

Please refer to: E9000 Server Mezz Card-Switch Module Networking Assistant
http://support.huawei.com/enterprise/NewsReadAction.action?newType=0301&contentId=NEWS1000004162&idAbsPath=0301_10001|1343902956248|1346221596290

END