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BIR server checked report data failed

Publication Date:  2016-06-25 Views:  56 Downloads:  0
Issue Description
After run some times, BIR server checked report data failed.
Alarm Information
none
Handling Process
 analyze process

1、  Get bir server log, can not find any wrong information

2、  Get Datastation log, find that ICD_SERVICE table space full that result in bill written into DB failed.

Checks the ICD_SERVICE table space data table information, the first second largest detailed table are T_HPS_BILL_CALLHIST_HPS_CALL_DETAIL_RECORD.
Root Cause
       After  the  eSpace  CC server run a long time,  there  will be a large data in the DB, some data are very old, if not need you can delete them.  Also if you do not need HPS report function, you can close it.
Solution
     If customer do not need HPS report function, you can close this, follow the  steps as below:

1、  Stop inserting HPS bill to uidb.

a.       Log into AgentManagement as sysadmin user(Default password is Huawei@123).

b.      Click "Component Setting" on the top menu.

c.       Click the "Report Service" on the left menu.

d.      Change the "Outbound CDR" to "OFF".

e.       Click "save".

f.       Restart Agent Management.

2、  Stop the HPS daily jobs.

a.       Query the job id of the P_HPS_DAYLOG_CURSOR, Execute the following script:

SELECT JOB FROM USER_JOBS WHERE UPPER(WHAT)='P_HPS_DAYLOG_CURSOR;';

b.      Stop the JOB of the P_HPS_DAYLOG_CURSOR by the above result.

Execute the following script:

/*for example 800 is the job id*/

EXEC DBMS_JOB.BROKEN(800, TRUE);

COMMIT;

c.       Stop the other HPS daily jobs by refer above steps.

P_HPS_DAYLOG_AGENTDISP_REDO

P_AGGR_HPS_D

P_AGGR_HPS_M

Suggestions
none

END