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SIP Call not working on HG8242 with alcatel PBX

Publication Date:  2016-12-26 Views:  48 Downloads:  0
Issue Description

VOICE Call not working on HG8242


* Incoming call disconnect when pickup

* not able to make outgoing call to any other extension


Current Version 

 V1R06C00S125

Topology 

SIP Server ----OLT---Splitter---ONT-- analog phone 


Alarm Information

* Incoming call disconnect when pickup

* not able to make outgoing call to any other extension

Handling Process

Capture the logs from normal ONT HG8247 to HG8247

#

call use codec g711a


Capture logs from abnormal ONT HG8242 to HG8247 and viceversa

#

call show SIP Error 415 unsupported media type



#

disable all the other codec from ONT and only use G711a



Capture logs again and 415 error is solved but still call is unsuccessful


Here you can see that while using HG8242 , when HG8242 send 200 OK with SDP , PBX send ACK and BYE at the same time .

So we guess that maybe there are differences of 200 OK SDP between HG8247 and HG8242 



 Comparing 200 OK between HG8247 and HG8242 , we found that on HG8242 there is no 2833 info.

SO we guess that maybe PBX only accept 200 OK with 2833 info, otherwise PBX will deny .





Root Cause

 Comparing 200 OK between HG8247 and HG8242 , we found that on HG8242 there is no 2833 info. SO we guess that maybe PBX only accept 200 OK with 2833 info, otherwise PBX will deny .

Solution

download ONT XML from ONT WEB or use U2000 ONT VAS to enable 2833

END