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IVR extension does not goes through if it starts with the same number as the options menu

Publication Date:  2017-01-25 Views:  39 Downloads:  0
Issue Description

When the customer try to dial an extension at the IVR menu the IVR does not take the extension number and takes only the first digit as  menu option.

Example

If user try to dial extension 144 IVR will take only the "1" and not the 144 as a complete number-

Important: Extension supported is chosen already

Alarm Information
NA
Handling Process

need to open the IVR Script at the PBX web page download it and modify the next parameter:

PlayCollect 65535,65535,253,true,1,'#',' ','#','#',30,NumLen,calledNum,3,3,5

 

Change this number for the number of digits of the extension, on this case, extension 144 will be changed to 3

608 PlayCollect 65535,65535,253,true,3,'#',' ','#','#',30,NumLen,calledNum,3,3,5

save the file and upload again overwriting the current one
Root Cause
This parameter is not configurable at the web interface
Solution

Change this number for the number of digits of the extension, on this case, extension 144 will be changed to 3

PlayCollect 65535,65535,253,true,3,'#',' ','#','#',30,NumLen,calledNum,3,3,5

save the file and upload again overwriting the current one

END