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FusionAccessR5C30 VM login failure due to license limitation

Publication Date:  2017-04-12 Views:  50 Downloads:  0
Issue Description

Product:FusionAccess R5C30

Issue Description:

The customer report they have some users can't login their new created VMs, and get the error like below:

Alarm Information

Also there is an alarm generated on fusionaccess portal indicates the License Usage Exceeds the Threshold.

Handling Process

Ask the customer feedback how many VMs they are using currently, and what is the desktop group type (Full Copy or Link-Clone),and what is the license capacity.

The customer feedback they have 179 Full Copy VMs mapped to 179 domain users, and the license capacity is 184 which is larger than the user quantity.

But they had some old VMs already deleted and create new VMs, now 179 VMs in use.

 

 

 

 

Root Cause

The user license count will keep existing in database for 15 days if the user didn't login the VM.

Solution

1: Login the master GaussDB VM ;

2: su –gaussdba ;

3:gsql –d database name ;

4: Run command "delete from TBL_USERLOGININFO;" ---------------Manually delete the license usage count to 0;

5: service LICServicerestart----------------restart the license service.

Suggestions



If the customer delete old VMs and create new VMs for new users in short period, the old user will still occupy the license count in database for 15 days.

If the license capacity is not enough, then we can manually release the license count in database to let the new user can login the VM.



END