No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Ultrapath plugin of VMware vCenter can't work properly after upgrade VMware vCenter

Publication Date:  2017-06-30 Views:  96 Downloads:  0
Issue Description

Customer upgraded vCenter from v6.0U2 to v6.0U3 (basically a patch). After upgrade, whenever go to UltraPath plugin tab under the vSphere web client, the customer always get the following errors and corrupt dialogue boxes. Explorer is also incredibly slow. Customer tried to re-register the plugin but no joy.


Version information:

• vCenter Server Appliance 6.0 Update 2 (VMware-VCSA-all-6.0.0-3634788.iso)
• ESXi 6.0 Update 2 Hosts
• Plugin & Extension version V100R008C50SPC500 (OceanStor UltraPath V100R008C50SPC500_VMware_vSphere.zip)
• Internet Explorer 11

 

Handling Process

1. Check if the Ultrapath plugin files was destoried during the vCenter upgrade.

/etc/vmware
/etc/vmware/vsphere-client
/etc/vmware/vsphere-client/vc-packages
/etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
/etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity/com.storage.issp.ultrapathplugin-1.6.61
/etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity/com.storage.issp.ultrapathplugin-1.6.61/plugins

But all files listed above is normal.

2. Check the installation procedure of Ultrapath plugin, everything is normal.

3. Ask the customer provide the steps that he encountered the error. Then we noticed that port ID 9443 was not specified when login vCenter web portal.

Root Cause

For VMware vCenter 6.5, it's no need to specify the service port(9443) when login the web portal. But all of the other earlier versions are need to specify the port ID.

Solution

Specify the port ID 9443 to access the vCenter web portal.


END