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OceanStor 9000 slowness issue

Publication Date:  2017-08-10 Views:  98 Downloads:  0
Issue Description
 

1. Users accessing the OceanStor 9000 shared drive are facing slowness in copying/retrieving/deleting files.

Alarm Information
 

 

No alarms are generated with this regard from storage

Handling Process

 

1. Verify the speed of copy/retrieve from both sides

a. User side: By using software which will give the copy speed

b. Storage side: By observing the graph which will be amiable in the DFS (device manager) of OceanStor 9000.

2. Once this is verified, collect logs from the storage, and analyze the number of I/O operations done at that particular time interval when the slowness issue was reported.

 

Root Cause
 

The root Cause was customer was executing a lot of deleting operations (I/O) during the peak hours of the usage of the storage for copy/retrieve operations (I/O) by users. So the I/O operations rise above normal and the slowness was faced.

 

 

Solution
 

 

 

An auto script was deployed in storage, which will facilitate automatic time interval deciding when the I/O operations are low, i.e. during the non-peak hours and execute the delete operations (I/O) during this non-peak hours.

Suggestions

 

1. Advice customers not to perform delete operations during the peak hours of production, rather advice them to do so during the non-peak hours,

Or

2. Seek help from Huawei enterprise team to design a script to do the work during non-peak hours automatically.

 

 

 

END