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eSight is not accessible

Publication Date:  2017-10-11 Views:  158 Downloads:  0
Issue Description

Customer reported that when they access eSight they are able to get to the login page, but after login the page delivered by the webserver is blank.

Alarm Information

- No alarm , just Blank screen after login -

Handling Process

1. Checked the disk info of
eSight server

l 
Run the
Linux command df -h and view the
disk status of the Linux operating system. The disk still has an available
space of 38 GB. Therefore, the fault is not caused by disk space use-up

l 
Run the
Linux command df -i and check the
inodes of the file system. It is found that inodes have been used up. An inode
is a file index node of the Linux file system. The number of available inodes
(IFree) is 0 and new files cannot be created.

1.      
Because the Inodes are in full usage , we should
check files:

Enter the
dictionary : /opt/oracle/admin/esight/adump;

2.      
Delete the oracle logs files info:

Command: find . -type f -print0 -exec rm {} \;
> /dev/null;

3.      
After we execute the command of step 2, we can check
the Inodes number :

Command: watch df –i

Result: we can see that the number of IFree increase

4.      
After there was enough IFree info ,we
have restart the eSight service:

a)       
Stop the eSight service:

Command:
hares -offline NMSServer -sys PlatformPrimaster

b)       
Startup the eSight service:

Command:
hares -online NMSServer -sys PlatformPrimaster

c)        
Check the status of eSight service:

Command: hastatus

5.      
Check the status of primaster and secmaster:

Command: vradmin -g datadg repstatus datarvg

Result: it’s normal

After those operations we have checked the esight and
everything was ok.

Confirmed with customer that problem was solved.

 

 

Root Cause

A large number of Oracle audit logs and
archiving logs are generated. As a result, inodes of the Linux file system are
used up. After inodes are used up, the application program cannot create new
files, affecting the access to eSight.

Solution

1. Delete the oracle logs files info:

Command: find . -type f -print0 -exec rm {} \;
> /dev/null;

 

2. Modify the oracle audit log cleanup cycle
once a week.

  • Open the file: crontab –e
  • Modify the cleanup cycle: 59 23 * * 5

3.After there was enough IFree info 
restart the eSight service:

a)       
Stop the eSight service:

Command:
hares -offline NMSServer -sys PlatformPrimaster

b)       
Startup the eSight service:

Command:
hares -online NMSServer -sys PlatformPrimaster

 

END