No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

after configure ERPS, the ring is working linear

Publication Date:  2017-12-25 Views:  25 Downloads:  0
Issue Description

1.  In normal operation Gig 0/0/2 port is in Forwarding state and Gig 1/0/2 port is in Discarding state BUT whole ring becomes unreachable.
2.  When manually shutdown Gig 0/0/2 port, then Gig 1/0/2 port goes in forwarding state and ring becomes reachable.
3.  When Gig 1/0/2 port goes in Discarding state then again whole ring becomes unreachable.

below is the topo:


Handling Process

from our checking, customer configure ACL 4001 and apply it in system view. the last rule is set "rule permit"

acl name MAC 4001 

 description for MAC ACL

 rule 5 deny destination-mac 0180-c200-0000

 rule 10 deny destination-mac 0180-c200-0001

 rule 15 deny destination-mac 0180-c200-0002

 rule 20 deny destination-mac 0180-c200-0003

 rule 25 deny destination-mac 0100-0c00-0000

 rule 30 deny destination-mac 0100-0ccc-cccc

 rule 35 deny destination-mac 0100-0ccd-cdd0

 rule 40 deny destination-mac 0100-0ccc-cccd

 rule 45 deny destination-mac 0100-0ccd-cdce

 rule 1000 permit

The device is S5300-LI which using marvel chip, there is some wrong with the implementation mechanism. When match the permit rule, then will not transmit the ERPS message.

And as our checking, customer  just apply the acl 4001 in system view, other acl not apply in system view. so only this ACL will affect the ERPS service.

Root Cause

this issue is due to device named “pune-dig-cha-jaytub-r2-eas04” not transmit the ERPS message, so ring is unreachable when G0/0/2 port is in Forwarding state and G1/0/2 port is in Discarding state.

The device is S5300-LI which use marvel chip, there is some wrong with the implementation mechanism. When match the permit rule, then will not transmit the ERPS message.

Solution

with customer confirmation, the ACL 4001 is useless. so after removing the traffic-filter inbound with acl 4001 in system view. the ERPS works fine

END