No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

OceanStor 5300 V3 fail to set ACL for NFS

Publication Date:  2018-03-07 Views:  267 Downloads:  0
Issue Description

Customer failed to set ACL for storage NFS V3 share folder and saying “operation not supported” as following:

[root@srvweproc1-trf1 mnt]# setfacl -Rdm o::rwx Pet0015932419

  setfacl: Pet0015932419/: Operation not supported

Handling Process


1.       Check the storage version if it’s newer than V300R003C20. The NFS ACL feature is only supported by the version which is newer than V300R003C20.
Check the configuration file for the exact version:


In this case the version is V300R003C20SPH207 which can support the ACL feature.
2.       Check the NFS version. The NFS ACL feature is only supported by NFS V3.

Check the mount parameters on the linux client by command “mount” or by fstab file:


3.       Check if the feature is enabled by storage.


Execute command “change service nfs support_v3_enabled=on v3_acl_enabled=on” in cli mode. Note: you should remount the file system after the ACL feature is enabled.








 

Root Cause

The ACL feature is not supported by the storage version or is not enabled on storage

Solution

Upgrade storage version to the latest (newer than V300R003C20) and then enable the ACL feature.

END