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Part of ISUP incoming calls to same subscriber rejected, because of SIPTG setting and peer side improper behavior

Publication Date:  2018-03-22 Views:  54 Downloads:  0
Issue Description
peer (non-neighbour) office sent calls to SOFXT3000 SIP-subscriber.
some calls is OK and some calls (to same subscriber) disconnected with reason "call rejected"



Alarm Information

release cause 21  «Call rejected»

Handling Process
1) collected traces for problem subscriber number.

2) found - calls coming to this subscriber from different directions, some was OK and some was rejected, even from same direction..

3) incoming IAM has some differences in values:
ForwardCallIndicator>"NAtional/international flag" and 
called-party-number >internal-network-number-indicatord
and in fields (exist or not)

 location-number

echo-control-information

optional-forward-call-indicators

 parameter-compatibility-information

According all calls was found - IAMs with FCI>NAtional/international flag = international call was rejected.

4) according internal user LOG trace - was checked number analyze and call processing inside SOFTX3000.
found:
Office hunt and TG choosing completed sucessfully, and rejecting happened later.

5) checked SIPTG setting, related to subscriber. result as below:

Basic information

-----------------

     Trunk group number  =  ***

       Trunk group name  =  *******

        Group direction  =  Bidirectional trunk

     Call-out authority  =  Intra-office

                         =  Local

                         =  Local toll

                         =  National toll

      Call-in authority  =  Intra-office

                         =  Local

                         =  Local toll

                         =  National toll

                         =  International toll

                         =  Intra-office national toll

                         =  Intra-office international toll

                         =  Intra-office local toll
So, calls can't be sent to this TG, if it is international call, because of SIPTG authority settings.
Root Cause

problem calls has indicator of International call in IAM (forward call indicator) International call are prohibitted to be routed to the called SIP TG.


All calls was national, but nature of call is determined by Forward Call Indicator in IAM message, if it shown "international", call will be processed as international

in our case - IAM's to same subscriber comed with different National/international flag in IAM FCI.

International calls - restricted to be outgoing (from SOFTX) to Terminating Subscriber

National calls - allowed.


The main reason - improper IAM FCI, generated by peer side.

Solution
1) Peer side should  use correct Forward call indicator for normal call processing among routing. - this solution is preffered (correct)
2) If international calls can be allowed for this TG - settings of SIPTG should be cnhanged. if not - only solution 1 is applicable.
Suggestions
for call problem - try to minimize scope of problem calls, and check call flow according intrnal trace and SOFTX3000 configuration.

END