No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Unable to Attach a Disk to a VM (Fusion Compute)

Publication Date:  2018-07-31 Views:  218 Downloads:  0
Issue Description

Customer reported an issue that, unable to add disk to one of the VM and below is the error message:-


FusionCompute V100R006C00U1SPC002 Platinum Edition




Alarm Information

There is no any alarm related to this VM.

Handling Process

Checking the disks attached to the VM and task running on this VM as shown below :-

 

There is only 2 disks attached to the VM.

 

There is no any running tasks for this VM under FusionCompute :-

 

 

Further checking, customer using BCManager and the backup task was running for the reported VM :-

 

Root Cause

Due to backup task is running on the VM, customer unable to attach the disks to the VM.

After backup task completed, customer able to add the disk to the VM successfully.

Solution

Before adding disks to a VM ensure there is no running task for the VM.

Suggestions

On FusionCompute, we also need to ensure below before attach a disk to a VM.

•A non-shared disk can be attached to only one VM.
•A shared disk can be attached to a maximum of eight VMs at the same time.

•Do not create a spanned volume, logical volume manager (LVM), or software RAID to merge multiple disks as one partition on a VM.
•If multiple disks are merged as one partition, used space on the disks cannot be queried on FusionCompute.
•If a disk uses spanned volumes, used space on the disk cannot be queried on FusionCompute.
•Only disks created on virtualized data stores or FusionStorage storage can be attached to VMs protected by the host-based replication disaster recovery (DR) function. Other disks, such as disks that have been restored using file-level restoration, raw device mapped disks, local disks, and disks created on SAN storage, cannot be attached to the VMs.
•If the disk to be attached is a raw device mapping (RDM) shared volume, ensure that Tools has been installed on the target VM before attaching the disk to the VM and Tools is running properly.
•Before attaching a disk to a VM in the Running state, ensure that Tools has been installed on the VM and Tools is running properly.

END