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DHCP Users Connected to an ME60 Fail to Obtain IP Addresses Due to Inconsistent IP Addresses

Publication Date:  2013-09-29 Views:  57 Downloads:  0
Issue Description

Networking:

AP--Switch--(User side) ME60 (Network side)--AC

The AP was connected to the ME60 using VLAN. The ME60 functioned as the gateway of the AP. On the ME60, the remote DHCP server was configured as the AC. That is, the AP should obtain IP addresses from the AC through the ME60. However, the AP failed to obtain IP addresses.
Handling Process

Possible causes were as follows:

1. The ME60 configurations were incorrect.

2. A link was faulty.

3. The AC was faulty.

Based on the preceding possible causes, Huawei performed the following operations to diagnose the fault:

Checked the ME60 configurations but found no error. Pinged the AC from the ME60 and the operation was successful. The first two causes were excluded. Traced the MAC address of the AP and found that:

The ME60 received from the DHCP server the OFFER packet destined for the AP.

-[2009/6/22 16:34:41-][DHCPR][0023-8902-5120]:Receive OFFER packet successfully(Ciadd:0.0.0.0 Yiadd:172.16.32.3 Siadd:0.0.0.0 Giadd:172.16.32.1 chaddr:0023-8902-5120 RouteIP:172.16.32.1 SubMask:255.255.255.0 ServerId:222.174.192.22 lease:1800s   

However, the ME60 did not forward the OFFER packet to the AP. Therefore, the AP transmitted the discovery packets continuously. When the specified period elapsed, the BAS displayed the cause of the user failing to go online, as shown in the following:

------------------------------------------------------------------           

  User name          : SD-WH-GQHW-BS-2.M-02001000002...                         

  Domain name        : fit-ap-nm                                                

  User MAC           : 0023-8902-5120                                           

  User access type   : IPoE                                                     

  User access interface : GigabitEthernet2/0/1.2512                             

  Qinq Vlan/User Vlan: 0/2512                                                   

  User IP address    : 255.255.255.255                                          

  User ID            : 100734                                                   

  User authen state  : Authened                                                 

  User acct state    : AcctIdle                                                 

  User author state  : AuthorIdle                                               

  User login time    : 2009/06/22 17:12:48                                      

  User online fail reason: DHCP server no response                              

  -------------------------------------------------------------------           

  Are you sure to show some information?(y/n)[y]:  

Debugged IP addresses on the ME60 and found that the source IP address of the OFFER packet received by the ME60 was 222.175.193.178 but the DHCP server IP address configured on the ME60 was 222.174.192.22.

After receiving the OFFER packet, the ME60 checked the source IP address in the packet and found that the IP address was different from the DHCP server IP address configured locally. The ME60 considered the packet invalid and discarded it.

*2.2206331108 SD-WH-GQHW-BS-2.MAN IP/7/debug_case:Slot=1;                       

Receiving, interface = GigabitEthernet1/0/5, version = 4, headlen = 20, tos = 96

,                                                                               

pktlen = 369, pktid = 2298, offset = 0, ttl = 255, protocol = 17,               

checksum = 17582, s = 222.175.193.178, d = 172.16.32.1                          

prompt: Receiving IP packet from GigabitEthernet1/0/5   

The solution was to change the DHCP server IP address configured on the ME60 or the source IP address on the DHCP server to ensure that they were the same.

In this case, the DHCP server IP address configured on the ME60 was changed to 222.175.193.178 to resolve this issue.
Root Cause

The source IP address of the OFFER packet received by the ME60 was different from the DHCP server IP address configured on the ME60.

After receiving the OFFER packet, the ME60 checked the source IP address in the packet and found that the IP address was different from the DHCP server IP address configured locally. The ME60 considered the packet invalid and discarded it.
Solution

Solution 1: Change the DHCP server IP address configured on the ME60 to the packet source IP address on the DHCP server.

Solution 2: Change the packet source IP address on the DHCP server to the DHCP server IP address configured on the ME60.
Suggestions
None

END