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Users Connected to an ME60 Failed to Obtain IP address Due to an Incorrect Parameter Delivered by the DHCP Server

Publication Date:  2013-09-30 Views:  24 Downloads:  0
Issue Description

An ITMS domain under an ME60 running V100R005C01B01B was configured to manage terminals subscribed to a package provided by a carrier. The terminals obtained management addresses from the ME60 in DHCP mode over a specific VLAN so that a third-party ITMS could manage the terminals remotely. All terminals under the ME60 failed to obtain IP addresses.

<ME60-01>disp access-user domain itms                                 
  --------------------------------------------------------------------------    
  UserID  Username                Interface      IP address       MAC           
  --------------------------------------------------------------------------    
  1232    *********-ME60-01-0...  GE3/0/1.703    -                0026-ed49-1156
  2274    *********-ME60-01-0...  GE3/0/1.707    -                3087-3017-2889
  3229    *********-ME60-01-0...  GE3/0/1.707    -                6416-f0fd-fabd
……

The following alarm information was found on the ME60:

#Jan 30 17:35:37 2011 ********-ME60-01 AM/4/DHCPSVRDOWN:OID=1.3.6.1.4.1.2011.6.
8.2.2.0.4 DHCP server is down or IP remote pool is full. (PoolNo.=12,Server=192.
168.1.2,Router=10.57.0.1,VPN instance=ITMS-VPN2905)
Handling Process

Possible causes include:

1. DHCP configurations on the ME60 were incorrect.

2. The ME60 failed to communicate with the DHCP server.

3. Packet interaction with the DHCP server was abnormal.

Huawei performed the following operations to address the problem:

1. Checked the DHCP configurations on the ME60.

The configurations were correct.

dhcp-server group itmsdhcp
 dhcp-server 192.168.1.2 vpn-instance ITMS-VPN2905
ip pool itmsdhcp remote
 vpn-instance ITMS-VPN2905
 gateway 10.35.16.1 255.255.240.0
 dhcp-server group itmsdhcp
domain  itms  
 authentication-scheme   default0  
 accounting-scheme   default0 
 vpn-instance  ITMS-VPN2905 
 ip-pool itmsdhcp 

2. Pinged the third-party DHCP server from the ME60.

Pinging succeeded.

3. Traced DHCPR packets by enabling the debug switch.

The DHCP server sent offer packets to the ME60.

<ME60-01>debugging dhcpr packet
<ME60-01>terminal debugging
<ME60-01>terminal monitor
*13.2671934613 ********-ME60-01 DHCR/7/DCPRDBG:                                
  [ DHCPR Recv from server ] : =====                                            
  [ Xid   ]:79332480                                                            
  [ cmd   ]:2                                                                   
  [ Htype ]:1                                                                   
  [ Hlen  ]:6                                                                   
  [ Hops  ]:1                                                                   
  [ Secs  ]:0                                                                   
  [ Flag  ]:0                                                                   
  [ Ciadd ]:0.0.0.0                                                             
  [ Yiadd ]:10.57.15.217                                                        
  [ Siadd ]:0.0.0.0                                                             
  [ Giadd ]:10.57.0.1 chaddr:6416-f09b-bac9                                     
  [ Sname ]:                                                                    
  [ File  ]:                                                                    
  [ Option ]:-----                                                              
  Message type:OFFER                                                            
  Route ip:10.57.15.1                                                          
  Subnet mask:255.255.240.0                                                     
  Server id:192.168.1.2                                                         
  Dns:192.168.0.3 192.168.0.4                                                   
  leasetime:7200s                                                               
  Renewtime:3600s                                                               
  Rebindtime:6300s                                                              
  Option82 :RID:*********-ME60-01-0301-0045-GE,CID:0301-0045-GE 

However, the ME60 did not forward the received offer packet. According to the preceding data, Giadd and Route ip in the offer packet were different. Upon receiving an offer packet, the ME60 checked whether Giadd and Route ip were the same, and discarded the packet if they were different. After Route ip was changed to be the same as Giadd, the terminals obtained IP addresses properly.
Root Cause
Route ip delivered by the third-party DHCP server was incorrect.
Solution
Route ip was changed to be the same as Giadd.
Suggestions
Focus on parameter information in a procedure if the procedure itself is correct.

END