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The NTP Is Synchronized but There Is a Difference of Several Hours Between the Client and the Server

Publication Date:  2013-10-08 Views:  55 Downloads:  0
Issue Description
In various networking, when the NTP worked in client/server mode, the display ntp status command detects that the NTP client was synchronized with the server but the display clock command detected a time error (a difference with several hours). 
[
Quidway]display  ntp status
 clock status:
synchronized            ----------The clock was in synchronized state.
 clock stratum: 4
 reference clock ID:
12.12.12.1       
----------The desired server was selected.
[Quidway]display  clock
2013-05-16 09:02:51-08:00    --------The time was incorrect, with a difference with several hours from the correct time.
Thursday
Time Zone(China-Standard-Time) :
UTC-08:00
Daylight saving time :

         Name        : Day Light Saving Time
         Repeat mode :
repeat
         Start year  :
2005
         End year    :
2005
         Start time  :
second Tuesday September 12:32:05
         End time    :
11-23 12:32:05
         Saving time :
00:00:00    
Handling Process
Equipment time consists of three parts: NTP UTC, time zone, and DST. The three parts are independent of each other. However, the equipment time is a combination of the three parts. 
1) The UTC time of the NTP is obtained from the server. The time zone and DST of the server are not transferred by NTP. 
2) The time zone is a fixed configuration for the local NE. 
3) The DST depends on the local configuration and the current date.
Root Cause
This problem was related to the time zone and DST configuration.
Solution
If the time on the client has a difference of several hours from the current local time:
1. If the difference is equal to the time zone value, the time zone of the server or the client may have not been configured.
2. If the difference is equal to two times the time zone value, the time zone configured on the server and the time zone configured on the client are reverse to each other.
3. If the difference is 1 hour, the DST has not been configured on the server or client.
4. If the difference minus the time zone value is 1 hour, the time zone may have not been configured on one device and the DST may have not been configured on the same or the other device.
Identify the problem the according to the actual problem symptoms.
Note that the time zone configuration various with the equipment version. If the time zone becomes reverse to its expected value after an upgrade or configuration modification, change it by referring to the specific equipment configuration manual.
Suggestions
If the client time is incorrect, check the NTP time, time zone, and DST configuration. If both the time zone and DST configurations are correct, run the following to check whether the NTP UTC of the server is correct:
<Quidway>display  ntp status
 clock status: synchronized
 clock stratum:
3
 reference clock ID:
LOCAL(0)
 nominal frequency:
63.9992 Hz
 actual frequency:
63.9992 Hz
 clock precision:
2^11
 clock offset:
0.0000 ms
 root delay:
0.00 ms
 root dispersion:
11.91 ms
 peer dispersion:
10.00 ms
 reference time:
03:24:02.868 UTC May 17 2013(D5402152.DE6E008E)       -
--------The UTC time is that obtained at the last time and has a maximum difference of 1024s from the current time. You can learn whether the UTC time of the server is correct based on the record.

END