No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

BFD session not established over VPLS from Alcatel (Using Vlan Aggregate)

Publication Date:  2014-10-22 Views:  59 Downloads:  0
Issue Description

    Is not possible to establish BFD session between the NE40E called RSA and RSB, when Vlan-aggregations is used, it’s possible to see the connection between the two routers is through the VPLS network which belongs to another vendor and they should transfer transparently the BFD packets but seems that’s not happening.

 

 

 

 

ANALYSIS:

 

For example in the device called RSA we can see how following Vlans are aggregated to the Vlan 40.

 

vlan 40

aggregate-vlan

access-vlan 500 2004

 

interface Vlanif40

description Conexion con CPA-IP

ip binding vpn-instance CPA-IP

ip address 200.11.174.162 255.255.255.248

vrrp vrid 200 virtual-ip 200.11.174.161

vrrp vrid 200 priority 150

 

interface G1/0/1 was associated to the access vlan 2004è

 

[RSA]int g1/0/1

[RSA-GigabitEthernet1/0/1]dis th

#

interface GigabitEthernet1/0/1

description Conexion con MetroEthernet SW3 (1/1/3)

undo shutdown

undo dcn

#

Return

[RSA-GigabitEthernet1/0/1]portswitch

[RSA-GigabitEthernet1/0/1]port trunk allow-pass vlan 2004

[RSA-GigabitEthernet1/0/1]undo port trunk allow-pass vlan 1

 

It was created the needed static BFD, as follow using the multicast address as peer device since the interface G1/0/1 is layer 2è

 

[RSA]bfd link1 bind peer-ip default-ip interface GigabitEthernet1/0/1 source-ip 200.11.174.162

[RSA-bfd-session-link1] discriminator local 10

[RSA-bfd-session-link1] discriminator remote 11

[RSA-bfd-session-link1] commit

 

Same configuration was replicated in the device called RSB and when was checked the BFD session was possible to see that it never went up.

 

[RSA]dis bfd session all

--------------------------------------------------------------------------------

Local Remote     PeerIpAddr      State     Type         InterfaceName          

--------------------------------------------------------------------------------

8192  8192       172.16.10.3     Up        S_AUTO_IF    GigabitEthernet1/0/0.2101

8193  8193       172.16.11.3     Up        S_AUTO_IF    GigabitEthernet1/0/0.2111

8194  8192       172.16.12.4     Up        S_AUTO_IF    GigabitEthernet1/0/0.2121

8195  8193       172.16.13.4     Up        S_AUTO_IF    GigabitEthernet1/0/0.2131

8196  8194       172.16.14.4     Up        S_AUTO_IF    GigabitEthernet1/0/0.2141

8197  8195       172.16.15.4     Up        S_AUTO_IF    GigabitEthernet1/0/0.2151

8198  8196       172.16.10.4     Up        S_AUTO_IF    GigabitEthernet1/0/0.2101

8199  8197       172.16.11.4     Up        S_AUTO_IF    GigabitEthernet1/0/0.2111

8201  8200       172.16.14.3     Up        S_AUTO_IF    GigabitEthernet1/0/0.2141

8202  8201       172.16.15.3     Up        S_AUTO_IF    GigabitEthernet1/0/0.2151

8203  1          192.168.81.1    Up        S_AUTO_IF    GigabitEthernet1/1/0.2002

8204  1          192.168.82.1    Up        S_AUTO_IF    GigabitEthernet1/1/0.2003

8206  8203       172.16.12.3     Up        S_AUTO_IF    GigabitEthernet1/0/0.2121

8207  8204       172.16.13.3     Up        S_AUTO_IF    GigabitEthernet1/0/0.2131

10    11         224.0.0.184     Down      S_IP_IF      GigabitEthernet1/0/1   

--------------------------------------------------------------------------------

 

After previous was noticed was decided to use debugging of BFD packets to check if the preocess were running ok, but we found that packets in RSA and RSB are sent but are never received.

 

ON RSA:

 

Sep  3 2014 22:55:24.560.3-04:30 RSA BFD/7/Packet:Slot=1;

16:04669: Send BFD Packet :

MD(10) YD(11) Diag(0) State(1) P(0) F(0) TX(13500) RX(13500) DM(3)

Echo RX(0) Length(24) Ver(1) C(0) A(0) D(0) R(0)

TTL(255) DstPort(3784)

 

ON RSB:

 

Sep  4 2014 23:18:12.50.3 RSB BFD/7/Packet:Slot=1;

16:04669: Send BFD Packet :

MD(11) YD(10) Diag(0) State(1) P(0) F(0) TX(14500) RX(14500) DM(3)

Echo RX(0) Length(24) Ver(1) C(0) A(0) D(0) R(0)

TTL(255) DstPort(3784)

 

After all previous then was proceeded to try to establish the BFD session between the directly interface connected in the RSA and RSB also using Vlan-aggregation and was found that the BFD session was possible to be established:

 

ON RSA:

 

interface GigabitEthernet1/1/11

portswitch

description Conexion directa con RSB (1/1/11)

undo shutdown

port link-type trunk

port trunk allow-pass vlan 2004

 

<RSA>dis bfd session discriminator 10 verbose

--------------------------------------------------------------------------------

Session MIndex : 16406     (One Hop) State : Up        Name : link1         

--------------------------------------------------------------------------------

  Local Discriminator    : 10               Remote Discriminator   : 11       

  Session Detect Mode    : Asynchronous Mode Without Echo Function             

  BFD Bind Type          : Interface(GigabitEthernet1/1/11)                   

  Bind Session Type      : Static                                             

  Bind Peer IP Address   : 224.0.0.184                                        

  NextHop Ip Address     : 224.0.0.184                                        

  Bind Interface         : GigabitEthernet1/1/11                              

  Bind Source IP Address : 200.11.174.162                                     

  FSM Board Id           : 1                TOS-EXP                : 7        

  Min Tx Interval (ms)   : 10               Min Rx Interval (ms)   : 10       

  Actual Tx Interval (ms): -                Actual Rx Interval (ms): -        

  Local Detect Multi     : 3                Detect Interval (ms)   : -        

  Echo Passive           : Disable          Acl Number             : -        

  Destination Port       : 3784             TTL                    : 255      

  Proc Interface Status  : Disable          Process PST            : Disable  

  WTR Interval (ms)      : -                                                  

  Active Multi           : -                DSCP                   : -        

  Last Local Diagnostic  : No Diagnostic                                       

  Bind Application       : No Application Bind

  Session TX TmrID       : -                Session Detect TmrID   : -        

  Session Init TmrID     : -                Session WTR TmrID      : -        

  Session Echo Tx TmrID  : -                                                   

  PDT Index              : FSM-20B0008 | RCV-8 | IF-20B0000 | TOKEN-0         

  Session Description    : -                                                  

--------------------------------------------------------------------------------

 

 

According with all previous analysis is possible to see that when is used Vlan-Aggregation the BFD session is not possible to be establish when the interfaces used are passing through the VPLS but when the directly connection is used between

the routers it’s possible to see the BFD session can be established although Vlan-Aggregation is used, also when the VPLS network is used it’s possible to see that BFD packets are sent according to the debugging information but are never

received. With findings obtained up to now seems the issue is the VPLS network which belongs to other vendor but after local engineer confirmed with customer seems in his side there’s no any limitation to drop multicast devices or something like that, but is really strange too because when a sub-interfaces are used instead layer to interfaces seems according with local office BFD session can be established between the routers although the VPLS network is used. Could you give us a hand to try to find out why the BFD session cannot be established then Vlan-aggregation is used and VPLS network is used too? We suspect that maybe it is something with the MTU or IP header when Vlan Aggregate is implemented.

Handling Process
For the bfd for default IP, the packet isn't with the vlan. So the multicast packet will be dropped in VPLS network. 
Root Cause
For the bfd for default IP, the packet isn't with the vlan. So the multicast packet will be dropped in VPLS network. 
Solution

We can support the scene.

END