R2631E interconnects with the CISCO router and enable md5 authentication,ospf neighbor cannot be established

Publication Date:  2012-07-27 Views:  250 Downloads:  0
Issue Description
R2631E interconnects with the CISCO router and enable md5 authentication,ospf neighbor cannot be established
R2631E version is 1.74-0108,the configuration is:  
interface Ethernet1                                                           
    ip address 200.200.200.1 255.255.255.252                                    
    ospf enable area 0.0.0.0                                                    
    ospf authentication-mode md5  anhuinms  15                                  
  !                                                           
  ospf enable 
the configuration of Cisco router is
interface FastEthernet0                                                         
ip address 200.200.200.2 255.255.255.252                                       
ip ospf authentication-key line                                                
ip ospf message-digest-key 15 md5 anhuinms  
!  
router ospf 1  
log-adjacency-changes  
network 200.200.200.0 0.0.0.3 area 0。



 




Alarm Information
On R2631E, execute disp ospf error and detect the error is increasing: 215: OSPF: bad authentication key


Handling Process
On Cisco router, add area 0 authentication message-digest and the neighbor is established normally.
after amending, the configuration is:
interface FastEthernet0                                                         
ip address 200.200.200.2 255.255.255.252                                       
ip ospf authentication-key line                                                
ip ospf message-digest-key 15 md5 anhuinms                                     
speed auto                                                                     
!                                                                               
router ospf 1                                                                   
log-adjacency-changes  
area 0 authentication message-digest                                          
network 200.200.200.0 0.0.0.3 area 0



Root Cause
The Cisco router configuration:
The Cisco router requires the authentication type of all the routers in one area must be consistent, by default, the area does not support the attribute of the packet authentication.



Suggestions
None

END