E1VI承载语音流时路由器频繁打印告警

发布时间:  2012-07-26 浏览次数:  87 下载次数:  0
问题描述
组网如下:PBX通过E1VI板卡接AR2880,AR2880通过IP网络接另一侧的交换网络。PBX下挂电话终端,AR2880通过E1VI承载语音流。语音业务正常,但是每次PBX下的电话终端发起呼叫时,在AR2880上都会打印诸如“Invalid command 27 from host(codecm/pbxtran.C:1739)”的告警。业务没有受到影响。
告警信息
Invalid command 27 from host(codecm/pbxtran.C:1739)
处理过程
1、确认路由器的配置没有问题。
2、执行“display version”,发现E1VI板卡信息如下:  
      [Slot 5] E1VI     Hardware Version is 1.0, Driver Version is 2.7
      确认E1VI版本为2.7。
3、升级E1VI版本至3.4,再次进行语音测试,业务正常,并且告警消除。
根因
这条告警是E1VI打印出来的,这是由于E1VI的驱动版本过低引起的。当语音流通过E1VI时,上层软件的一些命令字E1VI不识别。所以E1VI打印该告警告诉上层软件这条命令不合法。但是由于本身E1VI不需要处理这些命令字,所以,语音流能够正常通过,业务不受影响。
建议与总结
目前中低端路由器主流的版本是VRP1.74和VRP3.4,软件版本更新较快,上层软件增加了很多关于语音板卡的命令字,而E1VI板卡的版本不会随着主机软件的升级同步更新,所以导致该问题。虽然不影响业务,但是频繁弹出的告警影响维护。建议运行语音的局点,在升级主机软件的时候,能够同步升级E1VI。

END