Users at MA5200F cannot Pass Authentication because They Change Internal Web Authentication Page

Publication Date:  2012-07-27 Views:  93 Downloads:  0
Issue Description
Static users at MA5200F use internal WEB authentication. Clients change the page in order that web authentication page can automatically save users’ password. Users add one new network segment to expanse capacity. However, use previous IP address and user can pass normally force web authentication and can access network. In fact, when the same computer changes into newly-added network segment, users can open web authentication page and then click authentication and should enter username and password. And it does not indicate whether authentication succeeds or fails.
Alarm Information
Null 
Handling Process
1. Users use previous IP address and can normally pass authentication. It indicates that configuration at MA5200F and internal web file is correct.
2.Turn on adjustment switch at MA5200F (or use service trace switch):
<MA5200F>debug web packet
<MA5200F>terminal monitor
<MA5200F>terminal debugging
When client is under authentication, it is  found that there is no authentication request information. Normally, receive auth req as the following web module:
* [2006/01/04 14:02:03-] WEB-8-07023000:                                        
packet received from socket( len = 60):                                         
ver     : 1                                                                     
type    : auth req                                                              
Method  : chap                                                                  
SerialNo: 13800                                                                 
ReqID   : 0                                                                     
UserIP  : x.x.x.x                                                       
ErrCode : 0                                                                     
AttrNum : 2 
3. Capture packets at terminal and find that client terminal does not send authentication request packet when users change address.
4. Check internal uploaded web page of clients and find that the page is changed and can save username and password. And it is related with IE buffer.  Clear IE buffer of client terminal and change IP address and test, and users can access network. The problem is solved.
Root Cause
Use internal web authentication and the page displays username and password, namely, it does not indicate whether authentication succeeds or fails. Relevant information about client terminal will enter MA5200F. Considering clients change web page and automatically save username and password, client terminal does not send authentication request information and user authentication fails if client terminal changes IP address.
Others: Another possible reason is that upload of internal web authentication page fails (e.g. using internal web page of different versions, and upload new page but not refresh). It also can cause the problem. If there is no other problem, upload all internal webpage and refresh it. 
Suggestions
Null 

END