Incorrect Configurations Lead to Abnormal Cost Values of OSPF Routes

Publication Date:  2012-07-27 Views:  112 Downloads:  0
Issue Description
Networking:
vlanif1011 (10.43.0.65/27)----CE04-NE40(vlanif40 10.43.0.126)----(vlanif40 10.43.0.125)CE03-NE40 (GE2/1/0.111 10.1.70.242)----(GE3/0/4.111 10.1.70.241) RT01-NE80E
Description:
Direct routes of Type 1 were imported into CE04-NE40.
The route viewed on CE03-NE40 was as follows:
<CE03-NE40>display ip routing-table vpn-instance ChinaMobile_NGN_SG 10.43.0.64
Routing Table : ChinaMobile_NGN_SG
Summary Count : 1
Destination/Mask       Proto      Pre       Cost        NextHop           Interface
10.43.0.64/27              O_ASE   150       11         10.43.0.126       Vlanif40
The cost value of the route 10.43.0.64/27 was 11.
The route viewed on the RT01-NE80E was as follows:
<RT01-NE80E>display ip routing-table vpn-instance ChinaMobile_NGN_SG protocol ospf
ChinaMobile_NGN_SG routing table : OSPF
Destination/Mask      Proto    Pre       Cost         NextHop               Interface
10.43.0.64/27           O_ASE   150     65546        10.1.70.242       GigabitEthernet3/0/4.111
However, the cost value of the route 10.43.0.64/27 became 65546. 
 
Alarm Information
Null
Handling Process
The configurations viewed were as follows:
Configurations on CE04-NE40:
#
interface Vlanif1011
ip binding vpn-instance ChinaMobile_NGN_SG
ip address 10.43.0.65 255.255.255.224
#
interface Vlanif40
ip binding vpn-instance ChinaMobile_NGN_SG
ip address 10.43.0.126 255.255.255.252
ospf cost 10
ospf network-type p2p
#
ospf 1 vpn-instance ChinaMobile_NGN_SG
import-route direct type 1
bandwidth-reference 10000
area 0.0.0.0
network 10.43.0.126 0.0.0.0
Configurations on CE03-NE40:
#
interface Vlanif40
ip binding vpn-instance ChinaMobile_NGN_SG
ip address 10.43.0.125 255.255.255.252
ospf cost 10
ospf network-type p2p
#
interface GigabitEthernet2/1/0.111
vlan-type dot1q vid 111
ip binding vpn-instance ChinaMobile_NGN_SG
ip address 10.1.70.242 255.255.255.252
ospf cost 10
ospf network-type p2p
#
ospf 1 vpn-instance ChinaMobile_NGN_SG
import-route direct type 1
bandwidth-reference 10000
area 0.0.0.0
network 10.43.0.125 0.0.0.0
network 10.1.70.242 0.0.0.0
Configurations on the NE80E:
#
interface GigabitEthernet3/0/4.111
vlan-type dot1q 111
ip binding vpn-instance ChinaMobile_NGN_SG
ip address 10.1.70.241 255.255.255.252
ospf network-type p2p
#
ospf 1 vpn-instance ChinaMobile_NGN_SG
asbr-summary 10.0.0.0 255.0.0.0
default-route-advertise always
import-route bgp type 1
spf-schedule-interval millisecond 100
bandwidth-reference 10000
stub-router
area 0.0.0.0
network 10.1.70.241 0.0.0.0
Careful checks on configurations revealed that the stub-router command was particular. Afterwards, it was confirmed that the cost of a route transferred through the stub-router command was increased by 65535. For the route 10.43.0.64/27, its cost value is 11 + 65535 = 65546. 
 
Root Cause
It is probably that the device is faulty. 
Suggestions
It is recommended to read the configuration manual more carefully and understand the meanings of related commands deeply. 

END