SuSE10操作系统中安装NetS DB出现error的解决办法

发布时间:  2012-07-17 浏览次数:  116 下载次数:  0
问题描述
在SuSE10操作系统中,安装SIG V100R005C03版本的NetS DB,提示error如下所示:

 
error: Failed dependencies:
        limal-nfs-server is needed by yast2-nfs-server-2.13.10-0.3.noarch
        limal-nfs-server-perl is needed by yast2-nfs-server-2.13.10-0.3.noarch
Install package yast2-nfs-server-2.13.10-0.3 error. 
告警信息
处理过程
在SuSE10 SP2镜像中,提取相关文件(已上传附件),拷贝到SuSE10系统中,执行如下命令:
 
# chmod +x limal*
# rpm –ivh limal-nfs-server-1.1.72-0.3.i586.rpm
# rpm –ivh limal-nfs-server-perl-1.1.72-0.3.i586.rpm
 
重新安装NetS DB即可。

 
根因
缺少依赖的软件包。
 
SIG V100R005C03版本要求操作系统为SuSE10 SP2,该操作系统版本更新了相关的软件包内容。而SuSE10使用的软件包版本不能满足NetS的系统要求。
建议与总结
建议本机保存一份SuSE10 SP2的系统镜像。
 
目前尝试安装P2P DBFlow DBSUF DB都不会出现此error,若其他模块出现软件包依赖性问题时,可直接从SuSE10 SP2镜像中提取所需的软件包。 

END