Abnormal Disk Mapped to the AS

Publication Date:  2012-07-17 Views:  99 Downloads:  0
Issue Description

The disk mapped from the VIS6000 to the AS is abnormal. For example, disks cannot be detected or cannot be read or written.

Alarm Information
None
Handling Process
1. Check that the cables between the AS and the VIS6000 are properly connected. 
  AS configured with FC HBAs
Check that the link indicator of the FC port is on.
  AS configured with network interface cards
Check that the link indicator of the iSCSI port is on.
NOTE:
If the AS, VIS6000, and storage array are connected with an FC or Ethernet switch, check whether the zone configurations of the FC switch or the VLAN configurations of the Ethernet switch are correct. For details, see documents related to the switch.
2. Log in to the ISM interface and view whether the status of the FC or GE service port that connects to the AS is normal. For details, see Querying Properties of the GE Service Port and Querying Properties of the FC Service Port in the Oceanspace VIS6000 Series Virtual Intelligent Storage System Initial Configuration Guide.
3. If CHAP authentication is enabled for the VIS6000, check that CHAP is activated for the AS too.
4. Check that the WWN or iSCSI initiator of the AS is consistent with the WWN or iSCSI initiator added to the host of the VIS6000.
5. Check the volume mapping status. 
  Mapping a volume to a host
For details on the mapping status, see Querying Information About a Host in the Oceanspace VIS6000 Series Virtual Intelligent Storage System Initial Configuration Guide.
  Mapping a volume to a host group
For details on the mapping status, see Querying Information About a Host Group in the Oceanspace VIS6000 Series Virtual Intelligent Storage System Initial Configuration Guide.
6. Check the status of the volume mapped to the host group.
For details, see Adding Router Information of a GE Service Port in the Oceanspace VIS6000 Series Virtual Intelligent Storage System Initial Configuration Guide.
7. Run the vxrestartvxvm command to reboot VXVM. Next, run the vxdisklist command to view whether the status of the disk group that the volume is mapped to is normal, as shown in Figure 1.
Figure 1 Returned results of the vxdisklist command 

As shown in Figure 1, if the STATUS is online shared, it indicates that the disk group is in the normal status. If the STATUS is dgdisabled, perform the following operations:
a. Run the delmap [-f] -i map id command to delete the mappings to the host or host group.
b. Run the vxdg deport dgname command to export the disk group. dgname refers to the name of the disk group to be exported.
c. Run the vxdg –sC import dgname command to import the disk group. dgname refers to the name of the disk group to be imported.
d. Run the vxvol –g dgname start volname command to repair the volume in the disk group. dgname refers to the name of the disk group to be imported and volname refers to the name of the volume to be repaired.
e. Run the vxprint –g dgname command to view whether the volume status is normal, as shown in Figure 2.
Figure 2 Returned results of the vxprint command 


f. Run the addmap {-hi host id|-gi host group id} -hl host volume id -dg disk group name -v volume command to remap the volume that has been deleted in the 7.a to the host or host group.
8. Log in to the management interface of the storage array and view whether the storage array has any fault.
If the storage array has fault, remove the fault according to related instructions. After removing the fault, log in to the ISM interface to scan the disks again. Then, carry out 6 and 7.
9. Scan the disks on the AS again.
10. If the fault persists, seek technical support.
For the details on how to seek technical support, see Contact Channels of Huawei Symantec.
Root Cause

The possible causes include:
• Connection failure between the AS and the VIS6000
• CHAP authentication configured
NOTE:
This is the right cause when the GE service ports of the VIS6000 and the AS are successfully connected.
• Abnormal virtual volume mapping status of the VIS6000
• Abnormal virtual volume status of the VIS6000
• VIS6000 background progress blocking
• Storage array failure

 

Suggestions
None

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