An Alarm on the Hot Spare Disk Is Reported Because No Hot Spare Disk Is Available

Publication Date:  2012-07-17 Views:  260 Downloads:  0
Issue Description
Related information about the product and version: CSS V100R001C01 Database Volume.
On the ISM interface, the 0xB0216000A A hot spare disk alarm is generated on a RAID card alarm is reported.
Alarm Information
None
Handling Process
Step 1     Run the MegaCli64 -pdlist -aall | grep Unconfigured -B12 command to check whether a spare hard disk exists, as shown in Figure 1-9.Figure 1-1  Viewing the status of the hard disk

 
l   If Firmware state of one hard disk is Unconfigured(bad), replace the disk, then go to Step 2.
l   If Firmware state of one hard disk is Unconfigured(good), go to Step 2.
Step 2     Run the MegaCli64 -pdhsp -set physdrv[E:S] -aall command to configure a hot spare disk.
physdrv indicates the hard disk to be checked, E andS in [E:S] indicate Enclosure Device ID and Slot Number respectively.
 Step 3     Run the MegaCli64 -pdlist -aall | grep Hotspare$ -B12 command to check whether hot spare disk is configured, as shown in Figure 1-8.

l   If Firmware state of one hard disk is Hotspare, go to Step 4.
l   Otherwise, contact technical support engineers.
 Step 4     Check whether the 0xB0216000A A hot spare disk alarm is generated on a RAID card alarm recovers from the ISM interface.
l   If yes, the fault is removed.
l   If no, contact technical support engineers.
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Root Cause
On the ISM interface, the alarm listed in Table 1-5 is reported.
Table 1-1  Alarm on the hot spare disk failure on an LSI RAID card
Alarm ID Alarm Name Alarm Cause Alarm Description
0xB0216000A A hot spare disk alarm is generated on a RAID card. l A hot spare disk is faulty.
l No hot spare disk is specified in the system, or the hot spare disk has been used when the RAID group was reconstructed.
l A hot spare disk is removed.
The device ([dev-name]) has no hot spare disk; location: cloud storage domain ([domain-name]), rack ID ([rack]), frame ID ([frame]).
1.         Check the disk online indicator according to the alarm information and detect the indicator is green, it indicates the disk state is normal.
2.         Log in on the maintenance terminal to the alarm device as the root user.
3.         Run the Run the MegaCli64 -pdlist -aall | grep Hotspare$ -B12 command to check whether a hot spare disk is configured. No hard disk whose Firmware state is Hotspare exists, indicating that no hot spare disk is specified in the system or the hot spare disk has been used when the RAID group was reconstructed.

If Firmware state of one hard disk is Hotspare, as shown in the red circle in Figure 1-8, it indicates that a hot spare disk is specified in the system.
Figure 1-1 Viewing the system hard disk

 
Therefore, the alarm is generated because no hot spare disk is configured or the hot spare disk has been used when the RAID group was reconstructed.
Suggestions
None

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