How to Clean the Useless Disk Information from the VIS?

Publication Date:  2012-07-19 Views:  223 Downloads:  0
Issue Description
If the mapping on the disk array is deleted before the hard disk is deleted from the disk group on the VIS6000, the following errors occur when you scan for hard disks on the VIS:
Errors occur on the VIS. The error information is as follows:
VIS CLI:root>vxdisklist
VxVM vxdisk ERROR V-5-1-558 Disk -: Disk not in the configuration
-            -         sds          201_group    failed was:sds         0
VxVM vxdisk ERROR V-5-1-558 Disk -: Disk not in the configuration
-            -         sdw          201_group    failed was:sdw         0
If you continue to map the disk LUN ID on the disk array, the disk LUN ID is reported to be used when you scan for hard disks on the VIS.
 
Alarm Information
None
Handling Process
If the mapping of the LUN is deleted but the LUN is not deleted on the disk array, do as follows: Step 1  Map the LUN with the source LUN ID to the VIS.
Step 2  Scan for hard disks on the VIS to recover the hard disk.
Step 3  Delete the hard disk from the disk group, and delete the mapping on the disk array.
Step 4  Scan for hard disks on the VIS.
If the mapping of the LUN is deleted and the LUN is deleted on the disk array, do as follows: Step 1  Run the following commands:
vxdg -g 201_group rmdisk sds
vxdg -g 201_group rmdisk sdw
Step 5  Scan for hard disks on the VIS.
In this way, the incorrect disk information is deleted from the VIS.
Root Cause
If the mapping on the disk array is deleted before the hard disk is deleted from the disk group on the VIS6000, the VIS considers the hard disk to be lost and the disk information is stored in the system.
Suggestions
Operate on the VIS strictly according to procedures; otherwise, faults occur.

END