An Error Occurred When Deleting An Optimized-Space Snapshot

Publication Date:  2012-07-19 Views:  160 Downloads:  0
Issue Description

If you delete an invalid snapshot when an RVG is created, the system prompts the V-5-1-10128 error.

Alarm Information
None
Handling Process
1. Restore the network between the production center and the disaster recovery center.
2. Run the vxprint -g diskgroup command to view the rlink name under the disk group to be restored.
diskgroup refers to the name of the disk group.
For example, the name of the disk group to be restored is muldg. Run the vxprint –g muldg command to view the result, and the information shown in Figure 1 is displayed.
Figure 1 Viewing rlink 
 
The displayed rlink name is rlk_129.62.161.200_rvg001.
3. Run the vxrlink –g diskgroup -f dit rlink command to separate the rlink from the disk group.
diskgroup refers to the name of the disk group and rlink refers to the name of the rlink.
For example, run the vxrlink –g diskgroup -f dit rlink command to separate rlink rlk_129.62.161.200_rvg001 from the disk group muldg, and then run the vxprint –g diskgroup command to view the result, and the information shown in Figure 2 is displayed.
Figure 2 Viewing rlink 
 
4. Run the vxvol –g diskgroup -f dis volume_name command to separate the data volume with a snapshot.
5. Run the vxedit –g diskgroup -rf rm snapvol command to delete an invalid snapshot volume.
6. Run the vxvol –g diskgroup assoc rvg volume_name command to mount the separated data volume to the RVG again.
7. Run the vxrlink –g diskgroup assoc rvg rlink command to mount the separated rlink to the RVG again.
8. Start synchronization.
a. Log in to the ISM interface.
b. In the navigation tree, click the Logical tab.
c. In the navigation tree, select the Replicate Volume Groups node.
d. Select the RVG on which synchronization is to be carried out.
e. Select the virtual IP address of the disaster recovery center.
f. Click the right mouse button, and choose Check and Set Replicate Status... from the shortcut menu.
g. Click the Start button in the Check and Set Replicate Status dialog box.
h. In the Start Replicating dialog box, select Synchronize or Asynchronize as the replication mode.
i. Click OK. The Info dialog box is displayed.
j. Click OK.
Root Cause

Factors such as a restart and restoration of a faulty disk may generate dirty data in the header of the log volume or cause an error on the log volume; thus making the RVG enter the passthru mode, which means that synchronization cannot start.

Suggestions
None

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