Collected System Logs are Incomplete Due to a Bug of the S6800E R2 Version

Publication Date:  2012-07-20 Views:  223 Downloads:  0
Issue Description
A customer detects a large amount of error code during preventive maintenance. The customer collects system logs after the storage system is restarted and feeds back the logs to Huawei Symantec R&D engineers. The R&D engineers find that the system logs are incomplete, which contains data only within one minute.
Alarm Information
None
Handling Process

This fault can be completely rectified only by upgrading the product version. The temporary solution is to communicate with customers and inform them that they need to accept incomplete system logs if they need to use the LUN copy function. If customers do not need to use the LUN copy function, they can suspend the LUN copy process according to the following procedure:

 

Step 1 Log in to the CLI.

 

Step 2 Run the debug command and type the password to enter the debug mode.

 

Step 3 Type mml to go to the human-computer interactive interface.

 

Step 4 Run the cpy settimer off command.

 

Step 5 Wait for a while and collect the logs again. Check whether the log information can be stored more than one minute.

Root Cause
The customer uses the S6800E R2 version which has an value-added LUN copy function. The function runs a process in the system and flushes the system logs. This is a common fault in all S5000 R2 storage products delivered before June, 2010. The fault is rectified in the version released in July.
Suggestions
It is recommended to upgrade the R2 version of all delivered products to a later version during preventive maintenance.

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