NVR Server Is Disconnected Abnormally

Publication Date:  2012-07-23 Views:  102 Downloads:  0
Issue Description

After you log in to the configuration tool, monitoring software, or the special player, the system displays Server disconnected. Then, the client is disconnected from the server automatically.

Alarm Information
None
Handling Process

• To locate the specific cause, do as follows:
    1. Choose Start > Run, and then enter cmd to open the command line window.
    2. Enter a ping command in the following format:
    C:\Documents and Settings\Administrator>ping [IP address of the server]
    3. If the system displays time out, it indicates that the network is disconnected. Check the network, and check whether the network cable is correctly connected. Check whether the server is forcibly powered off or restarted by others due to an exception.
• Make sure that the network connection is normal and the server runs normally. Then, start services as follows:
    1. Log in to the server through the SSH client tool.
    2. Log in to the server and enter the following command to access the /hinvs/scripts/ directory.
    cd /hinvs/scripts/
    3. Enter the following command to check whether service processes are started:
./nvsctrl status
? If a single-machine version is adopted, the service processes are displayed as follows.
? Checking for service PSM ....
? root     11010     1  0 10:31 ?        00:00:00 NVS_ClientAppSvr
? root     10960     1  2 10:31 ?        00:00:00 NVS_StoreSvr
? root     10967     1  0 10:31 ?        00:00:00 NVS_BusinessSvr
? root     11082     1  0 10:31 ?        00:00:00 NVS_PUGateway
? root     10948     1  0 10:31 ?        00:00:00 NVS_SysAdminSvr
? root     11304     1  1 10:31 ?        00:00:00 APA_Server
? If a multi-machine version is adopted, the service processes are displayed as follows.
? # ./nvsctrl status
? Checking for service PNM ....
? root     15425     1  0 10:35 ?        00:00:00 PNM_SOAPSvr
? root     15438     1  0 10:35 ?        00:00:00 NVS_PNM
? Checking for service PSM ....
? root     15231     1  0 10:35 ?        00:00:00 NVS_ClientAppSvr
? root     15182     1  1 10:35 ?        00:00:01 NVS_StoreSvr
? root     15192     1  0 10:35 ?        00:00:00 NVS_BusinessSvr
? root     15401     1  0 10:35 ?        00:00:00 NVS_PUGateway
? root     15170     1  0 10:35 ?        00:00:00 NVS_SysAdminSvr
? root     15421     1  0 10:35 ?        00:00:00 APA_Server
? root     15381     1  1 10:35 pts/2    00:00:01 ./snmpapp
? root     15273     1  0 10:35 ?        00:00:00 PSM_SOAPSvr
    NOTE:
    The result about PNM is displayed only in the multi-machine version.
    4. Start the services.
? If no service is started, enter the following command:
    ./nvsctrl start
? If a service is not started, enter the following command:
    ./nvsctrl restart

Root Cause

Possible causes for that a client is disconnected from the server are as follows:
• The network is unstable.
• An exception occurs on the server.

Suggestions

According to the process of troubleshooting this fault, you can know that the prerequisites for normal connection between a client and the server are as follows: The network is normal; the background services of the server run normally.

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