Failure to Connect to the Database

Publication Date:  2012-07-28 Views:  70 Downloads:  0
Issue Description
A message is displayed indicating a failure to connect to the database. In addition, the VSM server cannot be started
Alarm Information
None
Handling Process
l           Check whether the database has been started. If the database has not been started, start it manually.

Perform the following steps to check and start the database on Windows:

1.         Double-click the database icon on the Windows taskbar.

The SQL Server Service Manager dialog box is displayed.

2.         Check whether the database server is started.

?       If the Start/Continue option is gray, the database has been started.

?       If the database is not started, click Start/Continue to start the database server.



In the dialog box that is displayed, select the Auto-start service when OS starts option.

l           Check the communication between the VSM and database.

?       On Windows, see 20.22.1 Failure to Log In to the Database.

l           If the configuration file is damaged because the database user password has been changed illegitimately, re-set the password for the database user.

l           Take the associated measures to handle othe database exceptions.

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Root Cause
The possible causes are as follows:

l           The database is not started.

l           The communication connection between the database and the server is set improperly.

l           The database password is illegally modified, which causes that the configuration file is damaged.

l           Other problems regarding the database occur.
Suggestions
None

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