DSM client failed to automatic authenticate

Publication Date:  2012-12-05 Views:  199 Downloads:  0
Issue Description
DSM V1R2 version client AD accounts carries on the authentication, found that the manual authentication has no problem, but automatic authentication failed.
Alarm Information
None.
Handling Process
1, through viewing the log of client AD authentication (Authentication.log), judge the connection between client and AD has problem, at the same time, the client can manual authenticate, namely the client itself has no problem, log is as follows:
02/27/2012 08:25:00 File: ".\model.cpp"; Line: 469; : SSPI InterFace function InitializeSecurityContext return Value:80090311
The corresponding error scene is: No authority could be contacted for authentication. AD failed to connect KDC.
2, check the status of the two tables AD domain server, found the main AD server itself has a problem, not the DSM system problem, positioned the problem, the customer can through recover AD master server fault to solve the problem. 
Root Cause
The primary domain controller of the two sets of primary/secondary AD domain has a problem, lead to the client failed to communicate with AD domain controller when authenticating automatically, but the DSM server has configured the secondary domain controller, it does not affect the results of manual authentication.
Suggestions
AD automatic authentication, need the DSM client and AD domain controller and DSM server authenticate at the same time;
AD manual authentication, it only needs the DSM client communicates with server, and then DSM server communicates with AD domain controller.

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