S5300交换机hybrid类型接口由于未取消默认配置(untag vlan 1)导致在发生广播风暴时产生拥塞

发布时间:  2014-09-12 浏览次数:  417 下载次数:  19
问题描述
1. 版本信息:

Huawei Versatile Routing Platform Software

VRP (R) software, Version 5.70 (S5300 V100R005C01SPC100)

2. 组网概述及故障现象:

                ( 外 部 网 络 )
         |                                      |
    S5300-1      =====      S5300-2
      |          |                          |         |
G0/0/1 G0/0/2                G0/0/1 G0/0/2
                  ( 用 户 侧 )


组网情况大致如上,S5300-1和S5300-2是网络中的两台交换机。除中间链路为trunk外其余端口都是hybrid类型,两个G0/0/1对应于vlan201、两个G0/0/2对应于vlan202。在受到外部网络广播风暴影响时,用户侧的四个接口同时发生丢包甚至业务中断现象。将左边的G0/0/1和右边的G0/0/2的端口属性改为access类型并分别加入各自所在vlan,两端口可正常通信(两个vlan之间可通过三层接口交换报文)。
告警信息
处理过程
1. 发生广播风暴时access类型的端口可正常通信而hybrid类型的不行,肯定是二者的配置有所不同,查看配置并未发现问题:

access端口:
[S5300-1-GigabitEthernet0/0/1]display this
#

interface GigabitEthernet0/0/1

port link-type access

port default vlan 201

#

hybrid端口:
[S5300-2-GigabitEthernet0/0/1]display this

#

interface GigabitEthernet0/0/1

port hybrid pvid vlan 201

port hybrid untagged vlan 201

#

2. 观察发现hybrid端口指示灯异常闪烁而access端口正常,分别做端口映射并抓包,又发现hybrid端口发出的报文中除了有少量与access端口相同的vrrp协议报文(各个vlan的三层接口下都起了vrrp)外,还有大量的DHCP报文。

3. 试着将与外部网络连接的端口先shutdown然后再undo shutdown,上述DHCP广播报文先消失、后又逐渐增多、直至后来增加越来越快并导致观察端的PC反应迟钝。

4. 检查交换机中vlan存在情况,重点怀疑vlan1。在hybrid端口下执行命令”undo port hybrid vlan all " 后看到有“undo port hybrid vlan 1”配置信息增加,原因已明确。

5. 恢复配置“port hybrid pvid vlan 201”和“ port hybrid untagged vlan 201”后,hybrid端口拥塞消除,可以正常通信。最终配置如下:

access端口:
[S5300-1-GigabitEthernet0/0/1]display this

#

interface GigabitEthernet0/0/1

port link-type access

port default vlan 201

#

hybrid端口:
[S5300-2-GigabitEthernet0/0/1]display this

#

interface GigabitEthernet0/0/1

undo port hybrid vlan 1

port hybrid pvid vlan 201

port hybrid untagged vlan 201

#

根因
配置原因:

S5300交换机上hybrid类型端口默认对vlan 1报文是untag的(不显示),当在hybrid端口上配置与access端口实现相同功能时易忽略这一点,导致在vlan1存在广播风暴时拥塞端口,进而影响端口下的业务。在广播风暴刚发生时问题尚不严重,之后逐渐有丢包,最后会由于拥塞严重而使业务中断。执行“undo port hybrid vlan 1" 命令后vlan 1的广播报文对端口的影响消除,业务恢复。


建议与总结
1. 各产品的默认配置往往不同,最好能在最初配置的时候查明未显示的默认配置,做到指令的准确性(既不少配、也不多配),以保证在特殊情况(如本例中的广播风暴的影响)下业务还能正常进行。本例中在hybrid端口下执行命令“port hybrid untag vlan 1” 后“display this”,端口配置未显示变化,或者执行命令“undo port hybrid vlan 1”后“display this”可看到配置有变,如此可查明默认配置。

2. 本例中问题产生的另外一个原因为广播风暴,当网络结构较复杂或存在链路冗余时最好能及时配上STP等协议。如果本例中的广播报文增加到足够多,交换机中即使未发生广播风暴的vlan也可能会受到影响。

END