S7700交换机,运行OSPF协议组网时,两端网络类型设置不一致,导致路由学习不正常的故障

发布时间:  2014-09-12 浏览次数:  182 下载次数:  0
问题描述
1、客户在调整DS_01和CS_01的线路和配置后,导致支行网点不能正常访问总部业务
2、组网结构如下图所示:
告警信息
支行业务人员反映,网点主机(地址为10.112.0.1)无法正常访问总部业务
处理过程
1、在总部核心交换机DS_01(S770)上查看路由表如下:
[DS_01]dis ip rout
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 9        Routes : 9      

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

     10.1.0.253/32  OSPF    10   1           D   10.1.1.2        Vlanif10
     10.1.0.254/32  Direct  0    0           D   127.0.0.1       LoopBack0
       10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
       10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
      10.1.20.0/24  Direct  0    0           D   10.1.20.1       Vlanif20
      10.1.20.1/32  Direct  0    0           D   127.0.0.1       Vlanif20
      10.1.30.0/24  OSPF    10   2           D   10.1.1.2        Vlanif10
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
发现没有到支行主机10.112.0.1 的路由器
2、查看DS_01的ospf邻居状态:
[DS_01]dis ospf peer

  OSPF Process 1 with Router ID 10.1.0.254
   Neighbors

Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s neighbors
Router ID: 10.1.1.2         Address: 10.1.1.2      
   State: Full  Mode:Nbr is  Master  Priority: 1
   DR: 10.1.1.2  BDR: 10.1.1.1  MTU: 0  
   Dead timer due in 31  sec
   Retrans timer interval: 5
   Neighbor is up for 04:56:14   
   Authentication Sequence: [ 0 ]

   Neighbors

Area 0.0.0.0 interface 10.1.20.1(Vlanif20)'s neighbors
Router ID: 10.1.0.252       Address: 10.1.20.2     
   State: Full  Mode:Nbr is  Slave  Priority: 1
   DR: None   BDR: None   MTU: 0  
   Dead timer due in 35  sec
   Retrans timer interval: 5
   Neighbor is up for 00:00:06   
   Authentication Sequence: [ 0 ]
发现router id 为10.1.0.252 的邻居状态为full
3、询问客户维护人员有无对现网设备进行操作,客户反馈调整过DS_01和CS_01的互联线路和接口配置
查看DS_01接口配置
interface Vlanif20
description to CS_01
ip address 10.1.20.1 255.255.255.0
ospf network-type p2p
interface GigabitEthernet0/0/2
description to CS_01
port link-type access
port default vlan 20
查看CS_01接口配置
interface Vlanif20
description to DS_01
ip address 10.1.20.2 255.255.255.0
interface Ethernet0/0/1
port link-type access
port default vlan 20
发现DS_01和CS_01互联接口一端ospf的网络类型为P2P,另一端为默认值(交换机默认为Braodcast)
4、同步修改CS_01和DS_01的互联接口ospf网络类型为P2P
interface Vlanif20
description to DS_01
ip address 10.1.20.2 255.255.255.0
ospf network-type p2p
5、ospf重新收敛后,查看DS_01路由表,可以学习到支行主机(地址为10.112.0.1)的路由如下:

<DS_01>dis ip rout
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 11       Routes : 11      

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

     10.1.0.253/32  OSPF    10   1           D   10.1.1.2        Vlanif10
     10.1.0.254/32  Direct  0    0           D   127.0.0.1       LoopBack0
       10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
       10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
      10.1.20.0/24  Direct  0    0           D   10.1.20.1       Vlanif20
      10.1.20.1/32  Direct  0    0           D   127.0.0.1       Vlanif20
      10.1.30.0/24  OSPF    10   2           D   10.1.1.2        Vlanif10
     10.112.0.0/16  O_ASE   150  1           D   10.1.20.2       Vlanif20
     10.113.0.0/16  O_ASE   150  1           D   10.1.20.2       Vlanif20
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
6、支行和总部业务互访正常,故障解决
根因
由于网络调整,造成的路由学习不正常
建议与总结
两台交换机以太网连接,必须保证两边的链路类型是一致的,否则会导致不能正常进行路由学习

END