USG5530 VLANIF接口不完美支持三层组播业务的解决方案

发布时间:  2013-08-26 浏览次数:  277 下载次数:  0
问题描述
由于XX电视台作为XX直辖市的重要官方电视台,其业务系统的可靠性和稳定性要求极高。其所有业务系统均采用冗余架构。我司采用两台USG5530防火墙双机结构部署对其IPTV数据源做安全防护,在IPTV源和收录制播网络之间形成安全屏障,保障其IPTV源数据的安全流通和使用。同时,收录制播业务需要通过我司防护墙来提供跨VLAN的通信需求,在我司防火墙上启用了VLANIF接口来实施收录制播业务数据的路由。然而,在实际业务上线测试阶段,发现高清视频流经过防火墙后会出现花屏和延迟现象。
告警信息
处理过程
按照确立的分析思路和对策进行了如下处理:
1、直接将组播业务跳过防火墙,通过线网已有交换机来实施三层组播业务的处理;
   结果:长时间测试,高清视频流正常,不再花屏和延迟,播放清晰流畅。
   又将防火墙接回原有业务网络;
   结果:立马复现高清视频花屏和延迟,播放卡壳停顿。
第一条确认:确实是因为防火墙导致高清视频的花屏和延迟。
2、对防火墙双机配置、双机状态、上下行接口配置、IP路由、组播路由等信息做
排查,没有未发现任何异常,只是下行链路使用VLANIF接口,由于客户下行
有这种跨VLAN通信的需求,此处使用VLANIF接口完全是合理配置。且
VLANIF下的组播配置均正常。如下:
RP的服务范围配置:
pim
static-rp 172.25.0.250
接口配置:
interface GigabitEthernet9/0/0   /接收组播源接口/
ip address 10.8.251.41 255.255.255.248
igmp enable
pim sm
#
interface Vlanif501     /组播接口/
ip address 10.8.4.253 255.255.255.0
vrrp vrid 2 virtual-ip 10.8.4.254 slave
igmp enable
pim sm
组播路由配置:
ip route-static 172.24.0.0 255.255.0.0 10.8.251.42
ip route-static 172.25.0.250 255.255.255.255 10.8.251.42
ip route-static 192.168.12.0 255.255.255.0 10.8.251.42
ip route-static 192.168.192.0 255.255.255.0 10.8.251.42
    第二条确认:不是防火墙配置不精确导致高清视频的花屏和延迟。
3、检查设备的版本信息为V300R001C00SPC600,和研发人员核实对组播支持无缺陷。
第三条确认:不是防火墙版本导致高清视频的花屏和延迟。
4、仔细排查客户网络环境,未发现路由振荡等问题;
第四条确认:不是网络环境导致高清视频的花屏和延迟。
5、仔细分析和对比前四种诊断排查方法后,认为可能出现问题的原因可能是VLANIF
   接口对组播的支持不够全面导致的高清视频流花屏和延迟。
理论支撑:a、前期在做防火墙项目时,碰到过VLANIF接口对IPv6的支持异常情况;
          b、早期的防火墙的三层接口很昂贵,逻辑的VLANIF接口和真正的三层物
物理接口在工作机理上有区别的。
解决方案,将VLANIF接口更改为三层接口。配置如下:
原有配置:
interface Vlanif501
ip address 10.8.4.253 255.255.255.0
vrrp vrid 2 virtual-ip 10.8.4.254 slave
igmp enable
pim sm
interface GigabitEthernet9/0/1
portswitch
port link-type access
port access vlan 501
更改后配置:
interface GigabitEthernet9/0/1
ip address 10.8.4.253 255.255.255.0
vrrp vrid 2 virtual-ip 10.8.4.254 slave
igmp enable
pim sm
通过上述调整高清视频流花屏和延时问题解决。
根因
1、将所有组播业务跳过防火墙,确认是否是防火墙导致的高清视频流花屏和延迟。
2、仔细检查核对配置数据、确保不是配置不精确造成的问题。
3、检查设备的版本信息和研发人员确认该版本对组播的支持无缺陷。
4、确认组网不会存在路由振荡等问题导致组播业务受影响。
5、经验排查。
建议与总结
防火墙的VLANIF接口和物理三层接口的区别和差异?
主要从两种接口对IPv6、组播等功能的支持情况来探讨两种接口的差异。

END