Congestion Occurs upon a Broadcast Storm of the S5300

Publication Date:  2013-12-31 Views:  379 Downloads:  0
Issue Description
1. Version information:
Huawei Versatile Routing Platform Software: version 5.70
S5300: V100R005C01SPC100

2. Networking and fault symptom:

       (External network)
         |                                      |
    S5300-1      =====      S5300-2
      |          |                          |         |
G0/0/1 G0/0/2                G0/0/1 G0/0/2
                  (User side)

The S5300-1 and S5300-2 are deployed on the network. Interfaces on the link between the two switches are trunk interfaces. Other interfaces on the switches are all hybrid interfaces. Two G0/0/1 interfaces belong to VLAN 201, and two G0/0/2 interfaces belong to VLAN 202. Upon a broadcast storm from the external network, packet loss occurs on the four user-side interfaces, and even services are interrupted. After G0/0/1 on the S5300-1 and G0/0/2 on the S5300-2 are changed to access interfaces and then added to VLANs 201 and 202 respectively, the two interfaces can properly communicate (VLANs 201 and 202 can exchange packets through Layer 3 interfaces).
Alarm Information
None
Handling Process
1. Upon a broadcast storm, the access interface can communicate while the hybrid interface cannot. Check the interface configurations. It is found that the interface configurations are correct.
Access interface:
[S5300-1-GigabitEthernet0/0/1]display this
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 201
#

Hybrid interface:
[S5300-2-GigabitEthernet0/0/1]display this
#
interface GigabitEthernet0/0/1
port hybrid pvid vlan 201
port hybrid untagged vlan 201
#

2. Observe the interface indicators. The hybrid interface indicator blinks abnormally, and the access interface indicator is normal. Configure port mapping and capture packets. It is found that the hybrid interface has a few Virtual Router Redundancy Protocol (VRRP) packets (VRRP is enabled on Layer 3 interfaces in each VLAN) that are the same as those on the access interface, and a large number of Dynamic Host Configuration Protocol (DHCP) packets.
3. Run the shutdown and undo shutdown commands in sequence on the interface connected to the external network. On the interface, no DHCP packet exists at first, but later the number of DHCP packets gradually increases. As a result, a large number of DHCP packets result in slow response of the observing client PC.
4. Check VLANs on the switch, and focus on VLAN 1. Run the undo port hybrid vlan all command on the hybrid interface. The configuration of the undo port hybrid vlan 1 command is automatically added.
5. Run the port hybrid pvid vlan 201 and port hybrid untagged vlan 201 commands. Congestion does not occur on the hybrid interface, and hybrid interface can properly communicate. The final configurations are as follows:
Access interface:
[S5300-1-GigabitEthernet0/0/1]display this
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 201
#

Hybrid interface:
[S5300-2-GigabitEthernet0/0/1]display this
#
interface GigabitEthernet0/0/1
undo port hybrid vlan 1
port hybrid pvid vlan 201
port hybrid untagged vlan 201
#
Root Cause
By default, the port hybrid untagged vlan 1 command is configured on the hybrid interface of the S5300. However, this default configuration is not displayed even after the display command is executed. This point is often ignored when the user configures the same VLAN on the hybrid and access interfaces. As a result, traffic congestion occurs on the hybrid interface upon a broadcast storm in VLAN 1, and services on the hybrid interface are affected. The problem is not severe at the beginning of the broadcast storm. Later, packets are gradually lost, and then severe congestion leads to service interruption. After the undo port hybrid vlan 1 command is executed, the impact of broadcast packets is eliminated, and services are recovered.
Suggestions
1. Products have different default configurations. You are advised to check the default configurations that are not displayed before configurations. Ensure instruction correctness so that services can run properly in special conditions, such as a broadcast storm in this case. In this case, when the port hybrid untagged vlan 1 and display this commands are executed in sequence on the hybrid interface, the displayed interface configurations remain unchanged. When the undo port hybrid vlan 1 and display this commands are executed in sequence, the displayed interface configurations are changed. In this way, the default configurations are verified.
2. Another cause for this fault is the broadcast storm. When the network structure is complex or link redundancy exists, it is recommended that protocols such as Spanning Tree Protocol (STP) be configured in a timely manner.

END