S5700和cisco6500做ET-trunk双链路捆绑拔插任意一条线都丢8个包

发布时间:  2014-04-15 浏览次数:  1630 下载次数:  17
问题描述

配置需求:A===》B通过ET-trunk 1做链路捆绑      B===》C通过ET-trunk 2做链路捆绑  都是通过2层互联都是双链路如上图所示。
具体配置:

C2960:
Switch#sh run int port-channel 1
Building configuration...

Current configuration : 54 bytes
!
interface Port-channel1
switchport mode trunk
end

Switch#sh run int g0/47
Building configuration...

Current configuration : 85 bytes
!
interface GigabitEthernet0/47
switchport mode trunk
channel-group 1 mode on
end

Switch#sh run int g0/48
Building configuration...

Current configuration : 85 bytes
!
interface GigabitEthernet0/48
switchport mode trunk
channel-group 1 mode on
End

S5700
#
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
bpdu enable
#
interface Eth-Trunk2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
bpdu enable
#
interface GigabitEthernet0/0/1
eth-trunk 1
undo ntdp enable                        
undo ndp enable
#
interface GigabitEthernet0/0/2
eth-trunk 1
undo ntdp enable
undo ndp enable
#
#
interface GigabitEthernet0/0/13
eth-trunk 2
undo ntdp enable
undo ndp enable
#
interface GigabitEthernet0/0/14
eth-trunk 2
undo ntdp enable
undo ndp enable
#

C6500

BJ-BS02-6509#sh run int port-channel 100
Building configuration...

Current configuration : 142 bytes
!
interface Port-channel100
description to test
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end
BJ-BS02-6509#sh run int g2/41
Building configuration...

Current configuration : 173 bytes
!
interface GigabitEthernet2/41
description to test
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 100 mode on
end

BJ-BS02-6509#sh run int g2/42
Building configuration...

Current configuration : 173 bytes
!
interface GigabitEthernet2/42
description to test
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 100 mode on
end

故障现象描述:A下的主机ping C上的一个ip地址在捆绑做完配置候(未断线)通不丢包
当断AB之间的一条链路丢2个包(拔插各一个正常)
当断BC之间一条链路的时候丢8个包(拔插各8个不正常)
告警信息
处理过程
检查配置基本没有问题:换场景测试我们把A接B的口和C接B的口对调配置不变断线ping结果还是和开始一样在断BC链路的时候丢包8个(拔插各八个不正常)

Cisco  A和C直接对接ping断线测试(配置不变)拔插各丢一个包正常

通过拨打400客服(单号2814229)给他说明情况和捆绑配置同时他让做了流量统计他们给出初步结论(57和65之间物理线路问题接口问题以及不同厂商兼容问题)


继续排查:
保持上面的配置不变继续测试(捆绑接口都是放行vlan  all)
通过上面的排查基本可以确定问题在B到C这两个交换机上。
故先测B到C之间捆绑链路是否有问题:
情景一
在B交换机S5700上接了一个pc机把该接口划分在业务vlan下ping 自己在Cisco交换机6500上的网关
现象:
不断线不丢包       断其中任意一条线丢8个包(拔线时丢8个再把链路恢复插上的时候也丢8个)
情景二
在交换机B s5700上配置了一个vlanif接口也是用该接口地址直接ping cisco交换机6500上的网关
现象:
不断线不丢包      断其中任意一条线丢一个包(拔插个一个)

得出结论:B和C也就是S5700和cisco6500之间的捆绑链路没有问题

情景三
我们又在交换机A 上配了一个vlanif接口用该地址ping C交换机cisco6500上的网关地址
现象:
不断线不丢包      断A和B之间的链路一根线丢1个包(拔的时候丢1个再插上丢一个)     
断B和C之间链路任意一根线丢8个包(拔插各8个包)

情景四
用A上的vlanif地址ping B交换机上的vlanif地址
现象:
不断线不丢包      断A和B之间任意一条链路丢一个包(拔插各一个)

得出结论:可能业务vlan的问题,但是我们都是放行所有vlan  和技术以及华为400沟通之后捆绑接口不放行所有vlan只放行业务vlan

修改配置:

S5700
#
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 4  999
bpdu enable
#
interface Eth-Trunk2
port link-type trunk
port trunk allow-pass vlan 4  999
bpdu enable
在A和C上也只放行业务vlan 4  999

测试:把两台pc接在交换机A c2960上分别归在vlan4和vlan999 然后ping  C交换机cisco6500上的网关地址

现象:
不断线不丢包        断A 和B之间的任意一条链路丢一个包(拔插个一个)
断B 和C之间的任意一条链路个丢一个包(拔插个一个) 
A和B与 B和C之间链路各任意断一条丢两个包(拔插各两个)
该测试现象正常

把现象反馈给400技术沟通得出结论:不同厂商之间兼容性问题,还有就是放行vlan all 不安全容易出问题实际工程中几乎不这样做 主要结论归结不同厂商BUG。
根因
可能配置出错,物理线路有问题,接口模块问题,工作速率工作模式(全双工半双工)不同厂商之间兼容性问题还有就是放行vlan。
建议与总结
在配置链路捆绑的时候我们尽量不要放行vlan  all这样安全性低以及容易出错,只需要具体放行业务vlan就可以了,同时与异场商做对接时的明白设备通用协议考虑到兼容性问题。再遇到问题应冷静思考,在解决不了的情况下及时寻求后方技术支持如400在传达信息时一定要全面仔细这样更能方便他们及时准确的给你解决问题!

END