标 题:AR路由器的V2R3版本软件 默认arp broadcast功能未打开,导致客户误解设备损毁,要求更换设备

发布时间:  2014-06-09 浏览次数:  292 下载次数:  0
问题描述
图中有三个不同网段;每个网段有若干PC连接交换机,通过单臂路由实现通信。客户现网整改,将AR路由器恢复出厂设置后,再配置,发现网络不通,没法恢复正常。但换另一台AR路由器,配置不变,网络却可以恢复正常,怀疑是AR路由器损毁。说明:现网AR路由器的软件版本是V2R3。

 
告警信息
网络不通告警。 
处理过程
1、 检查设备配置。
2、 使用wireshark抓包分析。
3、 考虑使用arp广播功能,建立单臂路由。
4、 在各个子接口配置命令arp broadcast enable。恢复网络。
[Huawei-GigabitEthernet0/0/0.1]display this
[V200R003C00]
#
interface GigabitEthernet0/0/0.1
dot1q termination vid 4
ip address 172.16.1.1 255.255.255.0
#
return
[Huawei-GigabitEthernet0/0/0.1]arp b
[Huawei-GigabitEthernet0/0/0.1]arp broadcast ena
[Huawei-GigabitEthernet0/0/0.1]arp broadcast enable
[Huawei-GigabitEthernet0/0/0.1]disp
[Huawei-GigabitEthernet0/0/0.1]display this
[V200R003C00]
#
interface GigabitEthernet0/0/0.1
dot1q termination vid 4
ip address 172.16.1.1 255.255.255.0
arp broadcast enable
#
return
[Huawei-GigabitEthernet0/0/0.1]
根因
1、 查看客户设备配置:
AR路由器:#
interface GigabitEthernet0/0/0
ip address 10.0.0.1 255.255.255.0
#
interface GigabitEthernet0/0/0.1
dot1q termination vid 4
ip address 172.16.1.1 255.255.255.0 
#
interface GigabitEthernet0/0/0.2
dot1q termination vid 2
ip address 172.16.2.1 255.255.255.0
#
interface GigabitEthernet0/0/0.3
dot1q termination vid 3
ip address 172.16.3.1 255.255.255.0
#
交换机:
#
vlan batch 2 to 4#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk pvid vlan 4
port trunk allow-pass vlan 4
#
interface GigabitEthernet0/0/3
port link-type trunk
port trunk pvid vlan 2
port trunk allow-pass vlan 2
#
interface GigabitEthernet0/0/4
port link-type trunk
port trunk pvid vlan 3
port trunk allow-pass vlan 3
#
PC 配置:
PC1:
Ip address:172.16.1.2
NetMask:255.255.255.0
Gateway:172.16.1.1

PC2:
Ip address:172.16.2.2
NetMask:255.255.255.0
Gateway:172.16.2.1

PC3:
Ip address:172.16.3.2
NetMask:255.255.255.0
Gateway:172.16.3.1


2、 从配置中看出,不同网段间,没有路由,数据包不清楚目的MAC,无法传送数据包。鉴于是单臂路由,因此加入arp广播使能,这样就能找到对端目的MAC,可使各接口通信。进一步使用Wireshark抓网络包分析:



 3、 那么客户另一台AR路由器,同样的配置命令,为什么能通信呢?那是因为两台AR路由器的软件版本不一致,在V2R3版本中arp   broadcast 是默认关闭的,而其它版本,是默认打开的。
建议与总结
1、 尽快更新现网中AR路由器软件版本,避免客户误解设备损毁。
2、 配置时,用到arp广播功能时,需要检查确认配置。

END