WLAN远端AP无法上线

发布时间:  2014-07-04 浏览次数:  103 下载次数:  0
问题描述
企业网某项目用华为的S5700替换思科的3750,下挂思科AP,替换完成后,下挂的交换机以及其他终端业务正常,但是无线网络不正常,发现AP无法注册上线
告警信息
处理过程
1、查看交换机上的mac以及arp信息,发现交换机上都学到了AP的mac以及ip信息,交换机上可以ping通AP的ip地址;
2、无线信号可以正常发射,但是依旧无法上网;
3、近端查看AP配置信息,发现AP的网关不在交换机上,网关指向了远端,地址为10.106.32.2
我们的交换机按照替换前的思科交换机的配置翻译过来的;
思科的关键配置如下:
!
interface Vlan100
ip address 10.106.32.161 255.255.255.224
!
 !
interface FastEthernet1/0/13
description to_ap_cabinetroom
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,133,135
switchport mode trunk
priority-queue out
spanning-tree portfast
service-policy input lenovo_att_classes_voip_data
ip dhcp snooping trust
!
华为的配置如下:
interface vlanif 100
ip address 10.106.32.161 255.255.255.224
#
interface GigabitEthernet0/0/13
description to_ap_cabinetroom
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 133 135
stp edged-port enable
bpdu enable
dhcp snooping enable
traffic-policy lenovo_att_classes_voip_data inbound
#
解决办法:在我们的设备上新增如下配置:
#
interface Vlanif100
arp-proxy enable
arp-proxy inter-sub-vlan-proxy enable
arp-proxy inner-sub-vlan-proxy enable
#
该问题解决
根因
可能是路由问题
建议与总结
遇到网关不在近端的情况下,需要使能arp-proxy服务;
或者更改网关到近端;上述问题也可以将AP的网关改为10.106.32.161 
两种办法均可解决该问题;但是建议使能arp-proxy服务;不对现网做更改

END