FusionAccess V100R005,Firefly客户端4.0无法安装

发布时间:  2014-07-27 浏览次数:  176 下载次数:  1
问题描述
客户在使用云桌面虚拟机,安装Firefly客户端4.0时提示报错:无法调取.NET Framwork 2.0或以下版本。安装.NET Framwork 2.0和1.1后,软件可以正常安装,但是打开软件是提示软件异常,无法打开。
告警信息
处理过程
联系软件厂家给出初步解决方案:在含有.Net Framwork2.0及以上版本时需要安装Visual J#2.0(测试安装后客户端可以正常打开);但是有机率存在客户端打不开或访问慢的问题,厂家研发建议:安装.NET1.1和J#1.1,并
使用1.1的config文件。
将下面四个config文件拷贝到Firefly Client的安装目录的bin目录下。默认为:C:\Program Files\Hansky\Firefly\Client\bin\
client_setting.exe.config、firefly_admin.exe.config、
firefly_client.exe.config、server_explorer.exe.config
说明:在存在.NET1.1和J#1.1的情况下,通过config文件指定用1.1版本的.NET和J#运行Firefly客户端,保证运行速度。
根因
1、Firefly客户端4.0无法在.NET Framwork 高版本(2.0以上)运行。需要指定Firefly客户端4.0调取时主动调取低版本的.NET Framwork或升级Firefly客户端4.0使其兼容高版本.NET Framwork 
建议与总结

END