MPLS L2VPN VLL , VC down 问题

发布时间:  2016-12-19 浏览次数:  356 下载次数:  0
问题描述
AR2240对接S7506,配置MPLS L2VPN VLL,接口up,管理PW也up,会话up,AC状态UP ,但L2VPN的VC一直显示down。

处理过程
打上对应的license,然后重启mpls进程后发现VLL正常。

根因
处理方式:在起的方式为MPLS L2VPN VLL的martini场景
首先检查VLL martini方式不能up
1)检查两端的封装类型及MTU是否一致
2)检查两端的VC ID是否一致
3)检查两端的control word配置是否一致

1) S7506配置
<shengting_s7506e>dis cu         //7506e
#
......
#
mpls lsr-id 15.185.254.2
#
vlan 1
#
vlan 44 to 69
#
vlan 100
#
vlan 1000
#
mpls
lsp-trigger all
#
l2vpn
mpls l2vpn reserve vlan 1818
mpls l2vpn
#
mpls ldp
#
mpls ldp remote-peer baisha
remote-ip 15.184.254.18
#
mpls ldp remote-peer baoting
remote-ip 15.184.254.19
#
.....
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
#
local-user admin
password cipher .]@USE=B,53Q=^Q`MAF4<1!!
authorization-attribute level 3
service-type telnet
#
interface NULL0
#
interface LoopBack0
ip address 15.184.254.2 255.255.255.255
#
interface Vlan-interface51
description vlink-haikou
mpls l2vc 15.184.254.51 51
#
interface Vlan-interface52
description vlink-sanya
mpls l2vc 15.184.254.4 52
#
...
#
interface Vlan-interface100
ip address 15.184.253.253 255.255.255.252                                           //与防火墙FW1000互联地址
#             
interface Vlan-interface1000
ip address 10.184.250.2 255.255.255.252                                                 //与公安网互联地址
mpls
mpls ldp
#
interface GigabitEthernet2/0/1
port link-mode bridge
port access vlan 1000
#
....
#
interface GigabitEthernet2/0/23
port link-mode bridge
port link-type trunk
port trunk permit vlan all
#
interface GigabitEthernet2/0/24
port link-mode bridge
port access vlan 1000
#
interface M-Ethernet0/0/0
#
ip route-static 15.184.0.0 255.255.0.0 15.184.253.254
ip route-static 15.184.254.1 255.255.255.255 10.184.250.1
ip route-static 15.184.254.3 255.255.255.255 10.184.250.1
....
ip route-static 15.185.0.0 255.255.0.0 10.184.250.1
#
load xml-configuration
#
user-interface aux 0 1
user-interface vty 0 4
authentication-mode scheme
protocol inbound telnet
user-interface vty 5 15
#
return        

检查发现两者都一致,再查看VLL是否需要license控制,display license发现AR2240未激活任何license。

查看手册且注意事项有如下说明:
• L2VPN功能使用License授权,缺省情况下,设备的L2VPN功能受限无法使用。如果需要使用L2VPN功能,请联系华为办事处申请并购买如下License:
 AR1200系列:AR1200数据业务增值包
 AR2200系列:AR2200数据业务增值包
 AR3200系列:AR3200数据业务增值包
• 设备不支持在VLAN 1上配置VLL功能。

初步分析为缺少license导致的无法使用L2VPN问题。
建议与总结
在配置MPLS L2VPN VLL的martini场景时,除了配置方面的检查,首先应确认是否对应功能需要license支持,特别是一些高级功能,比如IPv6,组播,MPLS VPN ,netsteam等功能。确保license已正确加载的前提下,再进行进一步排查,避免排查时走弯路。

END