Cisco PVST+与华为STP互联

发布时间:  2016-12-19 浏览次数:  528 下载次数:  0
问题描述
在以下拓朴中C4506运行PVST+,做为根网桥,核心设备无管理权限, S5700做为接入交换机运行STP,发现业务VLAN不能互通;
 
告警信息
配置华为交换机用于透传 Cisco 发出的 PVST+报文的端口不能启用 STP。
处理过程
配置华为交换机用于透传 Cisco 发出的 PVST+报文的端口不能启用 STP,否则 PVST+ 报文不能被转发,同时本端还会发送 BPDU,会干扰 Cisco 设备完成 PVST+计算。

相关命令:
在S5700上行接口做如下配置:
interface GigabitEthernet0/0/1                                                    
undo shutdown                                                                  
port link-type trunk                                                           
port trunk allow-pass vlan 10 20  (业务VLAN)                                 
stp disable     (关闭STP)                                                                 
                                                                               
interface GigabitEthernet0/0/2                                                     
undo shutdown                                                                  
port link-type trunk                                                           
port trunk allow-pass vlan 10 20 (业务VLAN)                                      
stp disable    (关闭STP)   
根因
Cisco PVST +协议报文会在数据帧内会带有 VLAN信息以外。PVST+ 协议的 BPDU 报文目的 MAC 地址是 01-00-0C-CC-CC-CD,因此该协议无法与采用 IEEE 标准生成树协议的设备进行互通。
建议与总结
1、PVST+ 协议的 BPDU 报文目的 MAC 地址是 01-00-0C-CC-CC-CD,因此该协议无法与采用 IEEE 标准生成树协议的设备进行互通。

2、于 Cisco 设备的 NATIVE VLAN 没有带 TAG,所以必须保证华为设备的 PVID 和Cisco 设备的 NATIVE VLAN 一致。(相关命令: [Huawei-GigabitEthernet0/0/1]port trunk pvid vlan 1)

END